ViPR SRM : Les quotas de fichiers VNX ne signalent pas de données
Summary: ViPR Dell EMC Storage Resource Management Suite (SRM) affiche un rapport vierge sur les quotas de fichiers. Les quotas sont configurés, mais l’API XML échoue avec une erreur d’espace de segment de mémoire Java due à une mémoire de segment insuffisante sur la station pilote. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Le rapport « File Components/Quotas » de ViPR SRM est vide et indique « This report does not select any data ».
Il a été vérifié que les quotas d’arborescence ont été configurés sur la ou les baies en question. Aucune erreur n’a été détectée dans les logs du collecteur VNX ou les logs LBC sur l’hôte du collecteur VNX pour la ou les baies dans les questions relatives aux quotas. Il n’y avait aucune référence aux quotas dans tous les journaux.
La commande suivante a été exécutée sur l’hôte ViPR SRM VNX Collector pour la ou les baie(s) en question à partir du chemin suivant :
/opt/APG/Collecting/Stream-Collector/emc-vnx/conf/requests : ./request sh -f <IP of ControlStation> -u XXXX -p XXXX -r vnxfile-quota.xml
La sortie suivante a été renvoyée par la commande dans le response.xml dans le répertoire /opt/APG/Collecting/Stream-Collector/emc-vnx/conf/requests :
<?xml version="1.0 » encoding="UTF-8 » standalone="yes » ?>
<ResponsePacket xmlns="http://www.emc.com/schemas/celerra/xml_api"><
PacketFault maxSeverity="error"
<>Problem messageCode="14227144705 » facility="Générique » component="API » message="Exception inattendue de nature inconnue. » severity="error"
><Description>Le serveur API XML a fait une exception inattendue. Cela ne signifie pas qu’il a cessé de fonctionner pour les autres utilisateurs. (Dans la plupart des casses, il s’agit d’une erreur de démarshalling de réponse APL).</Description>
<Action>Si le problème persiste, collectez les ressources de support en exécutant le script /nas/tools/collect_support_materials ou le script /nas/tools/automaticcollection plus récent. Notez tous les symptômes. Si vous avez besoin de plus d’informations sur le processus de collecte des documents, reportez-vous au Calendrier de résolution des problèmes pour Celerra, disponible sur EMC Powerlink ou au numéro de solution de support emc135846 de la base de connaissances EMC.
Pour plus d’informations, utilisez le texte de la brève description du message d’erreur ou l’ID du message pour effectuer une recherche dans la base de connaissances sur Powerlink. Après vous être connecté à Powerlink, accédez à Support > Recherche dans la base de connaissances > Recherche dans les solutions de support.</Action>
<Diagnostics>
Balise d’exception : 15cc1720d5e
Exception message : Java heap space
/Diagnostics>
</Problem><
/PacketFault><
/ResponsePacket< >
Cause
La baie back-end VNX ne dispose pas de suffisamment de mémoire du segment de mémoire Java allouée sur la station pilote pour que la demande se termine. Le paramètre par défaut de la mémoire du segment de mémoire Java est de 180 Mo.
Resolution
Augmentez la mémoire du segment de mémoire Java allouée sur la ControlStation de la baie VNX back-end à 256 Mo initialement. Si l’exception d’espace du segment de mémoire Java est toujours rencontrée, augmentez la mémoire du segment de mémoire Java à 512 Mo. Si vous avez besoin d’aide, augmentez le tas Java. Ouvrez un ticket auprès du groupe VNX.
Affected Products
Entry Level & Midrange, Storage SoftwareArticle Properties
Article Number: 000064529
Article Type: Solution
Last Modified: 09 Dec 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.