ViPR SRM: VNX-bestandsquota rapporteren geen data

Summary: ViPR Dell EMC Storage Resource Management Suite (SRM) geeft een leeg bestandsquotarapport weer; quota zijn geconfigureerd, maar de XML API faalt met een Java heap space-fout als gevolg van onvoldoende heap-geheugen op het ControlStation. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Het ViPR SRM-rapport "File Components/Quotas" is leeg en geeft aan: "Dit rapport selecteert geen data."

Er is geverifieerd dat de boomquota zijn ingesteld op de betreffende array(s).  Er zijn geen fouten gevonden in de VNX collector logs of LBC logs op de VNX collector host die verzamelen voor de array(s) in vragen met betrekking tot quota's.  Er was geen verwijzing naar quota's zoals allemaal in de logboeken.

De volgende opdracht is uitgevoerd op de ViPR SRM VNX collectorhost voor de array(s) in kwestie vanaf het volgende pad:

/opt/APG/Collecting/Stream-Collector/emc-vnx/conf/requests:  ./request sh -f <IP van ControlStation> -u XXXX -p XXXX -r vnxfile-quota.xml

De volgende uitvoer is geretourneerd door de opdracht in de response.xml in de map /opt/APG/Collecting/Stream-Collector/emc-vnx/conf/requests:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ResponsePacket xmlns="http://www.emc.com/schemas/celerra/xml_api"><
PacketFault maxSeverity="error"
<>Problem messageCode="14227144705" facility="Generic" component="API" message="Onverwachte uitzondering van onbekende aard." severity="error"
><Description>Er is een onverwachte uitzondering gemaakt voor de XML API-server.    Dit betekent niet dat het niet meer werkt voor andere gebruikers. (In de meeste gevallen is het een APL-antwoordfout).</Description>
 <Action>Als het probleem zich blijft voordoen, verzamelt u ondersteunend materiaal door het script /nas/tools/collect_support_materials of het nieuwere script /nas/tools/automaticcollection uit te voeren. Let op eventuele symptomen. Als u meer informatie nodig hebt over het inzamelen van materialen, raadpleegt u de Probleemoplossingsroadmap voor Celerra, beschikbaar op EMC Powerlink, of EMC Knowledge Base Support Solution nummer emc135846.

 Gebruik voor meer informatie de tekst uit de korte beschrijving van het foutbericht of de ID van het bericht om te zoeken in de Knowledge Base op Powerlink. Nadat u zich hebt aangemeld bij Powerlink, gaat u naar Support > Knowledge Base Zoeken > Supportoplossingen zoeken.</Action>
 <Diagnostics>
Exception-tag: 15cc1720d5e
Exception message: Java heap space
/Diagnostics>
</Problem><
/PacketFault><
/ResponsePacket<  >
 

Cause

De VNX-backend-array heeft niet genoeg Java-heap-geheugen toegewezen op het ControlStation om de aanvraag te voltooien.  De standaard Java-heapgeheugeninstelling is 180 MB.

Resolution

Verhoog het Java-heap-geheugen dat is toegewezen aan het ControlStation van de VNX-back-endarray in eerste instantie tot 256 MB.  Als de uitzondering voor de Java-heapruimte nog steeds wordt aangetroffen, verhoogt u het Java-heapgeheugen tot 512 MB. Als er hulp nodig is bij het verhogen van Java Heap. open dan een ticket bij de VNX-groep.

Affected Products

Entry Level & Midrange, Storage Software
Article Properties
Article Number: 000064529
Article Type: Solution
Last Modified: 09 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.