NetWorker: Oracle-back-up mislukt met lockbox-fout tijdens failover van NetWorker server
Summary: Bij een failover van de NetWorker clusterservice van het ene knooppunt naar het andere, is de Oracle-back-up mislukt met een lockbox-fout
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Er zijn geen veranderingen maar *@* werd weergegeven in het veld Remote Access van de NetWorker serverclientbron
Geen Oracle-back-up. U moet de clientwizard voor de RMAN-optie verwijderen of wijzigen om de back-up te laten werken op het failover-knooppunt
Tijdens de failover van de NetWorker clusterservice, is de Oracle-back-up mislukt met de volgende fout:
Oracle_Client: Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'.Confirm that the user 'xyz' on the host 'Oracle_Client' is in the Users attribute of the lockbox resource.
Geen Oracle-back-up. U moet de clientwizard voor de RMAN-optie verwijderen of wijzigen om de back-up te laten werken op het failover-knooppunt
Tijdens de failover van de NetWorker clusterservice, is de Oracle-back-up mislukt met de volgende fout:
Oracle_Client: Unable to obtain the user credentials from the lockbox due to the following error: 'Failed to open lockbox D:\nsr\lockbox\Oracle_Client\clb.lb'.Confirm that the user 'xyz' on the host 'Oracle_Client' is in the Users attribute of the lockbox resource.
Cause
Het externe toegangsveld van de NetWorker serverbron (de NetWorker clusternaam) heeft *@*.
Als *@* wordt weergegeven in de lijst met externe toegang, dan is er geen informatie in de RAP DB die NetWorker zou vertellen wat het andere knooppunt is, en NetWorker heeft niet de mogelijkheid om alle hosts te autoriseren (zelfs als dat wel het geval zou zijn, zou NetWorker dat niet doen, want dat zou een enorm gat in de beveiliging zijn. De lockbox op het actieve knooppunt is waarschijnlijk gemaakt op het actieve knooppunt en het passieve knooppunt is niet toegevoegd aan de lijst 'toegestaan' (dit is wat de foutmelding ‘De systeemhostnaamsleutel ontbreekt' betekent). Deze lockbox kan waarschijnlijk goed worden geopend op het andere knooppunt en heeft alleen een actief knooppunt in de lijst.
Als *@* wordt weergegeven in de lijst met externe toegang, dan is er geen informatie in de RAP DB die NetWorker zou vertellen wat het andere knooppunt is, en NetWorker heeft niet de mogelijkheid om alle hosts te autoriseren (zelfs als dat wel het geval zou zijn, zou NetWorker dat niet doen, want dat zou een enorm gat in de beveiliging zijn. De lockbox op het actieve knooppunt is waarschijnlijk gemaakt op het actieve knooppunt en het passieve knooppunt is niet toegevoegd aan de lijst 'toegestaan' (dit is wat de foutmelding ‘De systeemhostnaamsleutel ontbreekt' betekent). Deze lockbox kan waarschijnlijk goed worden geopend op het andere knooppunt en heeft alleen een actief knooppunt in de lijst.
Resolution
Voer de volgende stappen uit in het veld "Remote Access" van de NetWorker serverbron (NetWorker clusternaam):
*@Physical_Node1
*@Physical_Node2
Voer de back-up uit en alles is OK. De lockbox-informatie is correct bijgewerkt met beide fysieke knooppuntinformatie.
Het is niet nodig om de Oracle-client te verwijderen of te wijzigen
*@Physical_Node1
*@Physical_Node2
Voer de back-up uit en alles is OK. De lockbox-informatie is correct bijgewerkt met beide fysieke knooppuntinformatie.
Het is niet nodig om de Oracle-client te verwijderen of te wijzigen
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000067776
Article Type: Solution
Last Modified: 03 May 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.