Connectrix Brocade SANnav: SANnav-callhome-fejl pga. Uoverensstemmelse i SNMP-konfiguration mellem switchen og SANnav
Summary: Fra switchens supportsave- & SANnav-data blev det konstateret, at SNMP-traps ikke modtages fra switchen til SANnav
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Når du kontrollerer switchens SNMP v3-konfigurationer, konfigureres "Meddelelsestypen" som "Informer", men der er faktisk ikke aktiveret nogen "Meddelelser" fra SANnav-siden.
Cause
Der kunne ikke observeres logfiler, der viser, at SNMP-traps ikke modtages af switchen fra SANnav, men ud fra nedenstående oplysninger kan vi observere, om SNMP-traps modtages eller ej fra switchen til SANnav:
Fra SANnav tcpdump-dataene kan vi oprette et filter med udgangspunkt i "SNMP-trap" for at få vist oplysninger om, om vi får SNMP-traps eller ej fra switchen til SANnav.
Nedenfor findes oplysninger om SNMP-traps.
Fra SANnav tcpdump-dataene kan vi oprette et filter med udgangspunkt i "SNMP-trap" for at få vist oplysninger om, om vi får SNMP-traps eller ej fra switchen til SANnav.
Nedenfor findes oplysninger om SNMP-traps.
Resolution
Aktivér SNMP-traps fra den problematiske switch:
1. Log på den problematiske switch "1X.1XX.XX.XXX" med root-legitimationsoplysningerne.
2. Udfør kommandoen "snmpconfig --set snmpv3" i CLI for indstilling af SNMP v3-konfigurationen.
3. Efter udførelse af kommandoen og indstilling af SNMPv3-brugerkonfigurationen, i "SNMPv3 trap/inform recipient configuration", skal du ændre meddelelsestypen som "Trap" for trap recipientens adresse "1X.XXX.XX.XXX".
Eksempel:
SNMPv3 trap/inform recipient configuration:
Trap Recipients IP-adresse: [1X.XXX.XX.XXX]
Underret type [TRAP(1)/INFORM(2)]: (1.2) [2] 1
UserIndex: (1.6) [6]
Trap recipientEns prioritetsniveau: (0.5) [4]
Trap recipient Port: (0.65535) [162]
4. Når du har indstillet SNMPv3 trap/inform recipient-konfigurationen i CLI, skal du starte test-snmp-traps fra switchen.
Eksempel:
switch: root> snmptraps –send
antal sendte traps: 25
5. Omdøb det problematiske switchnavn fra SANnav for at få ægte SNMP-traps, og vend derefter tilbage til det oprindelige navn. <Dette er til testformål for at generere en ægte SNMP-trap og vente 1-2 minutter>
6. Kontrollér, om der genereres SNMP-traps-relaterede hændelser fra switchen på siden Hændelser.
Du kan finde oplysninger om "Informs" (Oplysninger) på siden "Fault Management > SNMP and Syslog Management > Registration" i SANnav GUI:

1. Log på den problematiske switch "1X.1XX.XX.XXX" med root-legitimationsoplysningerne.
2. Udfør kommandoen "snmpconfig --set snmpv3" i CLI for indstilling af SNMP v3-konfigurationen.
3. Efter udførelse af kommandoen og indstilling af SNMPv3-brugerkonfigurationen, i "SNMPv3 trap/inform recipient configuration", skal du ændre meddelelsestypen som "Trap" for trap recipientens adresse "1X.XXX.XX.XXX".
Eksempel:
SNMPv3 trap/inform recipient configuration:
Trap Recipients IP-adresse: [1X.XXX.XX.XXX]
Underret type [TRAP(1)/INFORM(2)]: (1.2) [2] 1
UserIndex: (1.6) [6]
Trap recipientEns prioritetsniveau: (0.5) [4]
Trap recipient Port: (0.65535) [162]
4. Når du har indstillet SNMPv3 trap/inform recipient-konfigurationen i CLI, skal du starte test-snmp-traps fra switchen.
Eksempel:
switch: root> snmptraps –send
antal sendte traps: 25
5. Omdøb det problematiske switchnavn fra SANnav for at få ægte SNMP-traps, og vend derefter tilbage til det oprindelige navn. <Dette er til testformål for at generere en ægte SNMP-trap og vente 1-2 minutter>
6. Kontrollér, om der genereres SNMP-traps-relaterede hændelser fra switchen på siden Hændelser.
Du kan finde oplysninger om "Informs" (Oplysninger) på siden "Fault Management > SNMP and Syslog Management > Registration" i SANnav GUI:

Affected Products
Connectrix SANnavArticle Properties
Article Number: 000217340
Article Type: Solution
Last Modified: 27 Nov 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.