Erro de conexão do OpenManage Enterprise CyberArk
Summary: O OpenManage Enterprise não consegue se conectar ao CyberArk Central Credential Provider (CCP).
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Symptoms
Ao configurar o OpenManage Enterprise para usar a integração do CyberArk, a conexão de teste retorna a seguinte mensagem de erro. 
Os logs do aplicativo mostram o seguinte erro de caminho do certificado.
[WARN ] 2024-09-19 21:11:46.053 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateCertChain - Unknown revocation status [WARN ] 2024-09-19 21:11:46.261 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateServerAndClientEku: Client & Server authentication EKU present in leaf certificate. [ERROR] 2024-09-19 21:13:46.232 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-8] CyberarkManagerImpl - verifyConnectionToCyberark: exception occurred while verifying the connection to cyberark. Message: I/O error on GET request for "https://pvwa.sumers.local:443/AIMWebservice/api/Accounts": PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target; nested exception is javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Cause
Esse problema ocorre porque os certificados CA do certificado carregado no OpenManage Enterprise for CyberArk não são carregados no truststore durante a criação do SSLContext para a conexão HTTPS.
Resolution
Esse problema será resolvido na próxima versão do OpenManage Enterprise 4.3.
Affected Products
Dell OpenManage Enterprise, Dell EMC OpenManage EnterpriseArticle Properties
Article Number: 000231597
Article Type: Solution
Last Modified: 08 Jul 2025
Version: 3
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