NetWorker-Service auf einem Linux-Client wird nicht gestartet, weil das Timeout überschritten wurde
Summary: Der NetWorker-Service auf dem Client wird nicht gestartet, da das Timeout überschritten wurde.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Der NetWorker-Service auf dem Client wird nicht gestartet.systemctl status Meldet ein Timeout.
# systemctl status networker.service networker.service - EMC NetWorker. A backup and restoration software package. Loaded: loaded (/opt/nsr/admin/networker.service; enabled; vendor preset: Active: failed (Result: timeout) Process: <PID> ExecStart=/opt/nsr/admin/networker.sh start (code=killed, Main PID: <PID> (code=exited, status=1/FAILURE)
systemctl start networker.service Meldet ein Timeout.
# systemctl start networker Job for networker.service failed because a timeout was exceeded.
Cause
NetWorker kopiert ein Startskript namens NetWorker ins Verzeichnis
Wenn sowohl ein
/etc/init.d. Es gibt auch ein Startskript namens networker.service Erstellt für systemdaus.
Wenn sowohl ein
systemd Serviceeinheit und eine init Skript mit demselben Namen vorhanden ist, kann es zu Konflikten kommen. Systemd Versucht möglicherweise, den Dienst mit beiden Methoden zu verwalten, was zu einem Timeout führt.Resolution
Verfahren:
- Entfernen Sie das NetWorker-Skript aus
/etc/init.d.
# mv /etc/init.d/networker /tmp/networker
- Überprüfen Sie, ob NetWorker aktiviert ist.
# systemctl is-enabled networker.service
- Starten Sie den Client neu.
- Überprüfen Sie den Servicestatus.
# systemctl status networker.service
Hinweis: Wenn das Problem nach Durchführung der oben genannten Schritte behoben ist, löschen Sie das Skript aus dem Speicherort, an den es kopiert wurde. In diesem Beispiel
rm -rf /tmp/networker
Article Properties
Article Number: 000269625
Article Type: Solution
Last Modified: 08 Feb 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.