Linux-asiakkaan NetWorker-palvelu ei käynnisty, koska aikakatkaisu on ylitetty

Summary: Asiakkaan NetWorker-palvelu ei käynnisty, koska aikakatkaisu on ylitetty.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Asiakkaan NetWorker-palvelu ei käynnisty.

systemctl status Ilmoittaa aikakatkaisusta.

# systemctl status networker.service
 networker.service - EMC NetWorker. A backup and restoration software package.
   Loaded: loaded (/opt/nsr/admin/networker.service; enabled; vendor preset: 
   Active: failed (Result: timeout) 
  Process: <PID> ExecStart=/opt/nsr/admin/networker.sh start (code=killed, 
Main PID: <PID> (code=exited, status=1/FAILURE)
systemctl start networker.service Ilmoittaa aikakatkaisusta.
# systemctl start networker
Job for networker.service failed because a timeout was exceeded.

Cause

NetWorker kopioi networker-käynnistyskomentosarjan kansioon /etc/init.d. On myös käynnistyskomentosarja nimeltä networker.service Luotu kohteelle systemd.

Jos molemmat a systemd Palveluyksikkö ja A init Skripti on olemassa samalla nimellä, voi olla ristiriita. Systemd Palvelua yritetään ehkä hallita molemmilla tavoilla, mikä johtaa aikakatkaisuun.

Resolution

Menetelmä:

  1. Poista NetWorker-komentosarja /etc/init.d.
# mv /etc/init.d/networker /tmp/networker
  1. Tarkista, onko NetWorker käytössä.
# systemctl is-enabled networker.service
  1. Käynnistä asiakas uudelleen.
  2. Tarkista palvelun tila.
# systemctl status networker.service

Huomautus: Jos ongelma ratkeaa edellä mainittujen vaiheiden jälkeen, poista komentosarja sijainnista, johon se kopioitiin. Esimerkissä rm -rf /tmp/networker
Article Properties
Article Number: 000269625
Article Type: Solution
Last Modified: 08 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.