タイムアウトを超えたためにLinuxクライアント上のNetWorkerサービスが開始されない

Summary: タイムアウトを超過したため、クライアント上のNetWorkerサービスが開始されません。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

クライアントのNetWorkerサービスが起動しません。

systemctl status タイムアウトを報告します。

# systemctl status networker.service
 networker.service - EMC NetWorker. A backup and restoration software package.
   Loaded: loaded (/opt/nsr/admin/networker.service; enabled; vendor preset: 
   Active: failed (Result: timeout) 
  Process: <PID> ExecStart=/opt/nsr/admin/networker.sh start (code=killed, 
Main PID: <PID> (code=exited, status=1/FAILURE)
systemctl start networker.service タイムアウトを報告します。
# systemctl start networker
Job for networker.service failed because a timeout was exceeded.

Cause

NetWorkerは、NetWorkerという起動スクリプトを /etc/init.d.という起動スクリプトもあります。 networker.service 作成対象 systemd.

両方の systemd サービスユニットと init 同じ名前のスクリプトが存在する場合、競合が発生している可能性があります。 Systemd が両方の方法を使用してサービスを管理しようとすると、タイムアウトが発生する可能性があります。

Resolution

手順:

  1. NetWorkerスクリプトをから削除します。 /etc/init.d.
# mv /etc/init.d/networker /tmp/networker
  1. NetWorkerが有効になっているかどうかを確認します。
# systemctl is-enabled networker.service
  1. クライアントを再起動します。
  2. サービスのステータスを確認します。
# systemctl status networker.service

注:上記の手順を実行した後で問題が解決した場合は、コピー先の場所からスクリプトを削除します。この例では rm -rf /tmp/networker
Article Properties
Article Number: 000269625
Article Type: Solution
Last Modified: 08 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.