PowerScale:SMBプロセスのaudit_fltドライバーがシャットダウン状態であり、ノードDUが発生しています
Summary: 監査ドライバーがSMBプロセスで正しくロードされないという問題がOneFS 9.7コードで特定されました。これにより、データ欠損(DU)につながる可能性があります。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
クラスターが9.7.1.0 - 9.7.1.6リリース コードの場合、この問題が影響する可能性があります。主な症状は次のとおりです。
- SMBユーザーは、一部またはすべてのノードにアクセスできません。
- 一部またはすべてのノードのSMBサービスが 、クローズ した状態で多数の接続を示しています。接続が閉じている状態は、さまざまな理由で発生する可能性がありますが、これはこの特定の問題に関連する症状でもあります。これを確認するには、次のコマンドを使用します。
isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
出力にはすべて 「0」 と表示されるはずです。以下は、この問題が発生しているクラスターの例です。
MyCluster-1# isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
MyCluster-1: 208
MyCluster-2: 425
MyCluster-3: 2228
MyCluster-4: 146
MyCluster-5: 5284
MyCluster-6: 964
- 監査がクラスターで有効になっています。次のコマンドで確認します。
isi audit settings global view | grep "Protocol Auditing"
MyCluster-1# isi audit settings global view | grep "Protocol Auditing"
Protocol Auditing Enabled: Yes
- クラスターは、影響を受けるコードを実行しています。9.7.1.0~9.7.1.6
クラスターでこの問題が発生しているかどうかを最終的に判断するには、 Dellサポートにサービス リクエストを発行します。これらは、LWIOサービスからのSMBコアダンプを調べるのに役立ちます。
Cause
この問題は、SMBプロセスが audit_flt ドライバーが起動します。この問題は通常、コードのアップグレード中、またはクラスター間のフェールオーバーとフェールバック中など、SMBサービスが再起動されたときにトリガーされます。ただし、何らかの理由でSMBが再起動された場合に発生する可能性があります。
Resolution
この問題を軽減するには、SMBサービスを再起動します。通常の状況では、分離されたSMB再起動で十分です。
MyCluster-1# killall -6 lwio
これは、複数のノードで実行できます。 isi_for_array.以下は、ノード1-4でSMBサービスを再起動する例です。
MyCluster-1# isi_for_array -n1-4 'killall -6 lwio'
これで問題が軽減されない場合は、SMBとすべての依存関係の再起動が必要になる場合があります。
MyCluster-1# /usr/likewise/bin/lwsm restart lwio
この場合も、複数のノードで同時に isi_for_array.以下は、ノード1-4でSMBスタックを再起動する例です。
MyCluster-1# isi_for_array -n1-4 '/usr/likewise/bin/lwsm restart lwio'
この問題は、OneFS 9.7.1.7コード以降で対処されています。
Affected Products
Isilon, PowerScale OneFSArticle Properties
Article Number: 000286634
Article Type: Solution
Last Modified: 22 Aug 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.