NetWorker SQL database backup forced to run level full

Summary: NetWorker SQL data base (DB) backup forced to run full when backup level is set to incremental or logs only.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker SQL database backup forced to run full when backup level is set to incremental or logs only.

Warning in nsrsqlsv log:

(pid7004) NSR critical 39 Failed to find matching recover object. 
(pid7004) NSR info 75 No full backupset was found for "database name"
Backup level forced to database full 

Cause

Indexes for the client are not generated on the NetWorker server. Messages in daemon logs of the NetWorker server:

File_index notice Notice: the index header for client is currently unavailable

Resolution

Run the command:
'nsrck -L6 client name' 
Next run the command: 
nsrinfo -n mssql clientname 
Confirm save sets are being listed by running the command:
nsrck -L6
The first backup would run level full and the consecutive backups are incremental or logs only if scheduled correctly.

Additional Information

Ensure below is checked as well:

  1. Database model is full.
  2. Previous database full backup exists.
  3. The last backup on the database was performed by using NMM.
  4. A log gap is not detected.

Affected Products

NetWorker, NetWorker Module for Microsoft

Products

NetWorker Family, NetWorker Module
Article Properties
Article Number: 000055541
Article Type: Solution
Last Modified: 30 Mar 2026
Version:  6
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