NVP-vProxy: Tworzenie kopii zapasowych kończy się niepowodzeniem z kodem nie znaleziono zasobu -404 "Aging out inactive session"

Summary: Tworzenie kopii zapasowych maszyny wirtualnej (VM) za pomocą urządzenia NetWorker VMware Protection (NVP) vProxy sporadycznie kończy się niepowodzeniem z powodu błędu "Nie znaleziono zasobu" (kod -404), ponieważ vProxy kończy ukończoną sesję tworzenia kopii zapasowych, zanim serwer NetWorker pobierze ostateczny stan. Duże opóźnienie sieci między węzłem pamięci masowej NetWorker a Data Domain powoduje, że serwer NetWorker opóźnia żądania sondowania stanu, co umożliwia wygaśnięcie sesji vProxy. Problem można rozwiązać zmniejszając opóźnienie węzła pamięci masowej do domeny danych poniżej 50 ms. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Integracja NetWorker VMware Protection (NVP) używa urządzenia vProxy do tworzenia kopii zapasowych maszyn wirtualnych. Tworzenie kopii zapasowych maszyny wirtualnej sporadycznie kończy się niepowodzeniem z komunikatem "Nie znaleziono zasobu" w konsoli NetWorker Management Console (NMC). Kolejna ponowna próba utworzenia kopii zapasowej dla tej samej maszyny wirtualnej może się powieść, ale niepowodzenie może mieć wpływ na inne maszyny wirtualne w tym samym oknie tworzenia kopii zapasowej. NMC wyświetla następujący błąd (identyfikator sesji różni się w zależności od wystąpienia):

{"Text":"Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9","Code":-404}

Dziennik akcji tworzenia kopii zapasowej pokazuje nieudane próby pobrania kopii zapasowej z serwera vProxy, a następnie niepowodzenie tworzenia kopii zapasowej:

MM/DD/YY HH:MM:SS [VM_NAME]: Unable to obtain backup status from vProxy after 5 attempts, failing the backup: Received an HTTP code: 404, libCURL message: "", vProxy message: "Error received from vProxy ="-404: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9". ", url: "https://[VPROXY_NAME]:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9", body: " ".
MM/DD/YY HH:MM:SS [VM_NAME]: Unable to download vProxy Session log into file '/nsr/logs/policy/VMWare Protection/[WORKFLOW]/461300-[VM_NAME]-YYYY-MM-DD-HH-MM-SS.log': Possible wrong vProxy hostname or port, resource path not found. Received an HTTP code: 404, libCURL message: "", url: "https://[VPROXY_NAME]:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9/log".
MM/DD/YY HH:MM:SS [VM_NAME]: Backup failed.
MM/DD/YY HH:MM:SS The size of proxied data written has not been set.
MM/DD/YY HH:MM:SS Save-set ID '849786629' (client '[VCENTER_NAME]': save-set 'vm:50308677-bf8b-c786-0140-6a9c4409b90f:[VCENTER_NAME]') is aborted.

Serwer vProxy vbackupd-engine.log pokazuje pełny cykl życia sesji — tworzenie kopii zapasowej zakończyło się pomyślnie po stronie vProxy, ale sesja jest następnie przestarzała i usunięta, zanim serwer NetWorker pobierze stan:

YYYY/MM/DD HH:MM:SS TRACE:  Ending go routine of main session loop for *resources.BackupVmSessions (vm-29424) [VM_NAME].
YYYY/MM/DD HH:MM:SS NOTICE: 44ab916f-7519-40f9-9d2e-e90394782ed9:vm-29424:[VM_NAME]: Backup session is exiting
YYYY/MM/DD HH:MM:SS TRACE:  Resource Update 44ab916f-7519-40f9-9d2e-e90394782ed9:externalId=[VCENTER_NAME]:vm-29424:state=Success:deletable=true.
YYYY/MM/DD HH:MM:SS INFO:   Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS NOTICE: Aging out inactive session BackupVmSessions - 44ab916f-7519-40f9-9d2e-e90394782ed9 ([VCENTER_NAME]:vm-29424) last accessed YYYY-MM-DD HH:MM:SS -0500 CDT.
YYYY/MM/DD HH:MM:SS TRACE:  Deleting logfiles of session '44ab916f-7519-40f9-9d2e-e90394782ed9'...
YYYY/MM/DD HH:MM:SS TRACE:  Deleting log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9"...
YYYY/MM/DD HH:MM:SS INFO:   File '/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log' is moved to '/opt/emc/vproxy/runtime/logs/recycle/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log'.
YYYY/MM/DD HH:MM:SS INFO:   Deleted log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9".
YYYY/MM/DD HH:MM:SS TRACE:  Deleting resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS INFO:   Deleted resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9.
YYYY/MM/DD HH:MM:SS INFO:   Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS INFO:   Aged out 1 'BackupVmSessions' sessions, 0 remaining
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE:  Handling Action GetLog for 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE:  Reply sent successfully for "GetLog".

Cause

Serwer NetWorker stale sonduje vProxy pod kątem stanu sesji kopii zapasowej i żąda dzienników sesji po zakończeniu tworzenia kopii zapasowej. vProxy kończy tworzenie kopii zapasowej i starzeje sesję po tym, jak serwer NetWorker nie zażąda aktualizacji przez kilka minut. Ponieważ sesja jest starsza, vProxy nie jest już w stanie przekazać serwerowi NetWorker aktualizacji stanu ani dzienników i kończy się niepowodzeniem z resource not found Błąd. Opóźnienia żądania stanu serwera NetWorker są zazwyczaj spowodowane dużym opóźnieniem między węzłem pamięci masowej NetWorker a komunikacją Data Domain.

Resolution

  1. Zmierz opóźnienie węzła pamięci masowej do domeny danych:
    • Uruchom ciągłe polecenie ping ze znacznikiem czasu z węzła pamięci masowej NetWorker do Data Domain i wyślij wyniki do pliku. Upewnij się, że strefy czasowe w obu systemach są zgodne.
      • Windows: 
        ping -t [DATA_DOMAIN_IP] > ping_output.txt
      • Linux:
        ping [DATA_DOMAIN_IP] | while read line; do echo "$(date): $line"; done > ping_output.txt
    • Pozostaw polecenie ping uruchomione w tle podczas tworzenia kopii zapasowej.
    • Gdy błąd tworzenia kopii zapasowej pojawi się ponownie, przejrzyj plik ping_output.txt i sprawdź zakres czasu odpowiadający awarii pod kątem skoków opóźnienia.
  2. Skróć opóźnienie poniżej 50 ms:
    • Zidentyfikuj i rozwiąż problem źródła dużych opóźnień między węzłem pamięci masowej NetWorker a systemem Data Domain. Typowe przyczyny to przeciążenie sieci, łącza WAN, nieefektywność routingu lub przeciążenie sprzętu sieciowego.
    • Upewnij się, że opóźnienie rundy między węzłem pamięci masowej NetWorker a Data Domain pozostaje poniżej 50 ms podczas wykonywania kopii zapasowej. Próg ten jest udokumentowany w sekcji "Zagadnienia dotyczące rozmiaru okna TCP i opóźnień sieci" w Podręczniku planowania optymalizacji wydajności Dell NetWorker.
  3. Wdrożenie węzła pamięci zdalnej (jeśli nie można zmniejszyć opóźnienia):
    • Jeśli nie można zmniejszyć opóźnienia węzła pamięci masowej do domeny danych poniżej 50 ms (na przykład z powodu separacji geograficznej), należy skonfigurować węzeł pamięci masowej NetWorker w zdalnej lokalizacji, w której znajduje się system Data Domain. Ten węzeł pamięci masowej zarządza urządzeniami Data Domain lokalnie, eliminując ścieżkę o dużych opóźnieniach.
  4. Sprawdź rozdzielczość:
    • Po zmniejszeniu opóźnienia lub wdrożeniu zdalnego węzła pamięci masowej uruchom zadania tworzenia kopii zapasowych dla maszyn wirtualnych, których wcześniej dotyczy problem.
    • Upewnij się, że tworzenie kopii zapasowych zostało pomyślnie wykonane bez błędów "Nie znaleziono zasobu" (kod -404) w NMC, dzienniku akcji tworzenia kopii zapasowej lub vbackupd-engine.log vProxy.
    • Monitoruj zadania tworzenia kopii zapasowych przez 3 kolejne okna tworzenia kopii zapasowych, aby upewnić się, że sporadyczne awarie już nie występują.
    • Jeśli błędy związane z przedawnieniem sesji nie ustąpią po zmniejszeniu opóźnienia poniżej 50 ms, skontaktuj się z działem pomocy technicznej firmy Dell w celu dokładniejszego zbadania sprawy i zapoznaj się z tym artykułem bazy wiedzy.

Additional Information

W następującym artykule szczegółowo opisano sposób rozwiązywania problemów z siecią: NetWorker: Jak rozwiązać problemy związane z siecią.

Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000034020
Article Type: Solution
Last Modified: 14 Jul 2026
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.