Avamar - Errore di ripristino Oracle "No backups with a label matching "

Summary: Questo articolo della Knowledge Base (KB) fornisce una soluzione alternativa per gli errori di restore Oracle causati da query lente di Avamar Server.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L'operazione di ripristino è lenta e potrebbe non riuscire con errori simili ai seguenti:
 

avtar Error <5183>: No backups with a label matching '' or backuptag 'c-555-444-ff' or labelnum 0 were found.
avtar Error <5920>: File 12/remsdev/CONTROLFILE.remsdev.c-555-444-ff not found.




 

Cause

Ripristino tramite autobackup significa che il software Oracle potrebbe eventualmente eseguire numerose query ad Avamar.
Se sono presenti più di 255 query di questo tipo e ogni query dura circa un minuto, il processo di ripristino rallenta notevolmente.


Esempio:

restore spfile to '/oracle/admin/remsdev/avamar/spfileremsdev.ora' from autobackup;

Resolution

Il modo migliore per ripristinare il spfile oppure controlfile è usando il suo vero nome invece di autobackupCosì:
 

run {
allocate channel c1 type sbt PARMS="SBT_LIBRARY=/usr/local/avamar/lib/libobk_avamar64.so" format '%d_%U';
send channel c1 '"--prefix=12/remsdev/CONTROLFILE.remsdev." "--flagfile=/oracle/admin/remsdev/avamar/my-avtar-flags.txt" "--bindir=/usr/local/avamar/bin"';
restore spfile to '/oracle/admin/remsdev/avamar/spfileremsdev.ora' from  CONTROLFILE.remsdev.c-12345-6789-01 ;
release channel c1;

Affected Products

Avamar, Avamar Plug-in for Oracle
Article Properties
Article Number: 000041592
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.