Avamar – chyba obnovení Oracle "No backups with a label match"

Summary: Tento článek znalostní databáze (KB) obsahuje zástupné řešení selhání obnovení systému Oracle kvůli pomalým dotazům na server Avamar.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Operace obnovení je pomalá a může nakonec selhat s chybami podobnými těmto:
 

avtar Error <5183>: No backups with a label matching '' or backuptag 'c-555-444-ff' or labelnum 0 were found.
avtar Error <5920>: File 12/remsdev/CONTROLFILE.remsdev.c-555-444-ff not found.




 

Cause

Obnovení pomocí autobackup To znamená, že software Oracle může na systém Avamar odeslat velké množství dotazů.
Pokud existuje více než 255 takových dotazů a každý dotaz trvá přibližně jednu minutu, proces obnovení se tím značně zpomalí.


Příklad:

restore spfile to '/oracle/admin/remsdev/avamar/spfileremsdev.ora' from autobackup;

Resolution

Nejlepší způsob, jak obnovit spfile nebo controlfile je použitím jeho skutečného názvu namísto autobackupNějak tak:
 

run {
allocate channel c1 type sbt PARMS="SBT_LIBRARY=/usr/local/avamar/lib/libobk_avamar64.so" format '%d_%U';
send channel c1 '"--prefix=12/remsdev/CONTROLFILE.remsdev." "--flagfile=/oracle/admin/remsdev/avamar/my-avtar-flags.txt" "--bindir=/usr/local/avamar/bin"';
restore spfile to '/oracle/admin/remsdev/avamar/spfileremsdev.ora' from  CONTROLFILE.remsdev.c-12345-6789-01 ;
release channel c1;

Affected Products

Avamar, Avamar Plug-in for Oracle
Article Properties
Article Number: 000041592
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.