PowerStore: Das Hinzufügen einer Appliance zu einem vorhandenen Cluster schlägt mit "Unconfigured Faulted" fehl.

Summary: Während der Installation des Assistenten für die Erstkonfiguration (ICW) oder beim Hinzufügen einer Appliance zu einem vorhandenen Cluster schlägt die Aufgabe mit "Unconfigured Faulted" fehl ...

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Symptoms

Während der Erstinstallation einer Appliance in einem neuen Cluster oder beim Hinzufügen einer neuen Appliance zu einem vorhandenen Cluster gibt es Hardware- und Netzwerkprüfungen, die fehlschlagen können. Dieser Fehler kann den Status der Appliance von "Unconfigured" zu "Unconfigured Faulted" ändern. Dieser Status bedeutet, dass die Appliance keinem neuen Cluster beitreten oder zu einem vorhandenen Cluster hinzugefügt werden kann. Der Fehler muss behoben werden, bevor die Appliance zu einem Cluster hinzugefügt werden kann.



 

Cause

Führen Sie die folgenden Schritte aus, um festzustellen, ob ein Hardware- oder Netzwerkproblem vorliegt, das den Zustand "Unconfigured Faulted" verursacht:

Resolution

Wenn Sie die Appliance zu einem vorhandenen Cluster hinzufügen (über PowerStore Manager):

  1. Greifen Sie mithilfe der Zugriffsmethode für den Service-LAN-Port auf das System zu (siehe PowerStore: Zugriff auf einen Node für Details).
  2. Sobald Sie sich beim Servicecontainer als Servicenutzer angemeldet haben, führen Sie das folgende Serviceskript aus, um festzustellen, ob ein Hardware- oder Netzwerkproblem vorliegt: 
    svc_diag list --icw_hardware
    svc_diag list --network

     

  3. Wenn keine Fehler oder Probleme gemeldet werden, ist es möglich, dass die ursprünglichen Symptome, die während des ICW- oder des Appliance-Add-Vorgangs beobachtet wurden, vorübergehend waren.
     
  4. Wenn ein Fehler oder ein Problem angezeigt wird und Sie nicht bestimmen können, wie Sie es beheben können, führen Sie das folgende Skript aus, um eine Datenerfassung zu erstellen, und wenden Sie sich an Ihren Serviceanbieter, um Unterstützung zu erhalten: 
    svc_dc run
     
  5. Wenn Sie eine Appliance in einem neuen Cluster installieren und die Installation wiederholen möchten:
    • Schließen Sie Ihr Discovery Tool und/oder Ihren Browser. 
    • Starten Sie das Discovery Tool neu oder öffnen Sie den Browser mit der statischen Service-LAN-IP-Adresse für Node A [d. h. 128.221.1.252].
    • Wenn das System anzeigt, dass es sich im Status "Unkonfiguriert" befindet, setzen Sie die Schritte für die Erstkonfiguration/den ICW fort
    • Wiederholen Sie den Vorgang zum Hinzufügen der Appliance, um festzustellen, ob die Aufgabe erfolgreich war.
       
  6. Falls die Aufgabe weiterhin fehlschlägt, führen Sie eine Datenerfassung durch, um relevante Protokolle zu erhalten, und wenden Sie sich an Ihren Serviceanbieter, um Unterstützung zu erhalten.

 

 

Im Folgenden finden Sie ein Beispiel für eine erfolgreiche Ausgabe von "  svc_diag list --icw_hardware " in der linken Spalte; Die rechte Spalte enthält Erläuterungen zu Fehlern, die möglicherweise angezeigt werden.

Beispielausgabe

Beschreibung

hw_type Warnado-EX
Running on Node A

 

Node A FRU Status

OK | Peer Node | 0x0f80
OK | Local Node | 0x1480
OK | Embedded Module | 0x8b81
OK | 4-Port Card | 0x8b81
OK | I/O Module 0 | 0x8b81
OK | I/O Module 1 | 0x8b81
OK | Internal Backup Battery Module | 0x3380

Node B FRU Status
OK | Peer Node | 0x0f80
OK | Local Node | 0x1580
OK | Embedded Module | 0x8b81
OK | 4-Port Card | 0x8b81
OK | I/O Module 0 | 0x8b81
OK | I/O Module 1 | 0x8b81
OK | Internal Backup Battery Module | 0x1380

Diese Tabellen bestehen aus drei Spalten:

 Zusammenfassung | Name der vor Ort austauschbaren Einheit (FRU) | Statussensorwert


 Die Spalte "Zusammenfassung" auf der linken Seite sollte wie folgt lauten:

OK = FRU-Status ist gut.


Leer = FRU fehlt und/oder wird von der Appliance nicht erkannt. Da I/O-Module optional sind, kann es normal sein, dass der Status "Leer" für I/O-Module angezeigt wird. (In diesem Fall müssen dieselben I/O-Modulsteckplätze auf beiden Nodes leer sein.) Alle anderen FRUs sind erforderliche Hardware und sollten immer den Status "OK" aufweisen.


Aus = FRU ist ausgeschaltet. Möglicherweise müssen die FRU ausgetauscht werden.


Unbekannt = Statussensorwert enthält unerwartete Werte. Möglicherweise müssen die FRU ausgetauscht werden.



 Empfohlene Maßnahme bei Fehlern:  Weitere Informationen zur Behebung dieser Hardwareprobleme finden Sie in den zugehörigen KB-Artikeln. Dazu gehören: 000132703, 000132707 (Nodes), 000125540 (I/O-Module, Karte mit 4 Ports) und 000132989 (integriertes Modul).

IO Module Consistency Check = Success
Node Consistency Check = Success
Battery Check = OK

 

Bei diesen Prüfungen werden die Werte der FRU-Statuszusammenfassung von jedem Node verglichen. Es wird erwartet, dass beide Nodes denselben Zusammenfassungswert für jede FRU melden.

 

Empfohlene Maßnahme bei Fehlern:

  1. Informationen zu I/O-Modulen finden Sie im KB-Artikel 000125540.
  2. Informationen zu Nodes finden Sie in den KB-Artikeln 000132703 und 000132707.
  3. Die Prüfung des internen Backup-Akkumoduls ist OK, es sei denn, der FRU-Status kann nicht von einem oder beiden Nodes gelesen werden. Wenn dies der einzige Fehler ist, der von der icw_hardware sollte ein Neustart des ICW ihn passieren lassen.
Node A Fault Status Register Status = Success
OK | Node
OK | Embedded Module
OK | Internal Backup Battery Module
Module
        OK | DIMM00
        OK | DIMM01
        OK | DIMM02
        OK | DIMM03
        OK | DIMM04
        OK | DIMM05
        OK | DIMM06
        OK | DIMM07
        OK | DIMM08
        OK | DIMM09
        OK | DIMM10
        OK | DIMM11
        OK | DIMM12
        OK | DIMM13
        OK | DIMM14
        OK | DIMM15
        OK | DIMM16
        OK | DIMM17
        OK | DIMM18
        OK | DIMM19
        OK | DIMM20
        OK | DIMM21
        OK | DIMM22
        OK | DIMM23
OK | I/O Module 0
OK | I/O Module 1
OK | 4-Port Card

Node B Fault Status Register Status = Success
OK | Node
OK | Embedded Module
OK | Internal Backup Battery Module
Module
        OK | DIMM00
        OK | DIMM01
        OK | DIMM02
        OK | DIMM03
        OK | DIMM04
        OK | DIMM05
        OK | DIMM06
        OK | DIMM07
        OK | DIMM08
        OK | DIMM09
        OK | DIMM10
        OK | DIMM11
        OK | DIMM12
        OK | DIMM13
        OK | DIMM14
        OK | DIMM15
        OK | DIMM16
        OK | DIMM17
        OK | DIMM18
        OK | DIMM19
        OK | DIMM20
        OK | DIMM21
        OK | DIMM22
        OK | DIMM23
OK | I/O Module 0
OK | I/O Module 1
OK | 4-Port Card

 

Die Statuswerte in der linken Spalte sind OK oder FLT. Diese werden aus dem Fehlerstatusregister (FSR) gelesen.


 "FLT" zeigt an, dass in der FRU ein Hardwarefehler aufgetreten ist.


Ein "OK" bedeutet, dass für diese FRU kein Hardwarefehler aufgezeichnet wurde. Wenn keine FRU vorhanden ist, sollte der Status in dieser Tabelle "OK" lauten. (Ein leerer I/O-Modulsteckplatz wird in diesen Tabellen als "OK" angezeigt, in der FRU-Statustabelle oben jedoch als "Leer" aufgeführt.)

 


Empfohlene Maßnahme bei Fehlern:  Weitere Informationen zur Behebung dieser Hardwareprobleme finden Sie in den zugehörigen KB-Artikeln. Dazu gehören: 000132703, 000132707 (Nodes), 000125540 (I/O-Module, Karte mit 4 Ports) und 000132989 (integriertes Modul). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NVRAM Cache Drives
Node Core Counts (NodeA:12, NodeB:12)
Number of NVRAM Drives Required based on Core Count: 2
NVRAM Drives Found (NodeA:2, NodeB:2)
NVMe Storage Drives
Number of NVMe Drives Required: 6
SCM Drives Found (NodeA: 0, NodeB: 0)
SSD Drives Found (NodeA: 12 (NVMe 6, SAS 6), NodeB: 12 (NVMe 6, SAS 6))
NVMe Drive Check = Success
compareNodeDrives - NVEe Drive Counts, NodeA 8, NodeB 8
compareNodeDrives - Both Nodes see same NVMe drives
compareNodeDrives - SAS SSD Drive Counts, NodeA 12, NodeB 12
compareNodeDrives - Both Nodes see same drives
Compare Node Drive Check = Success
checkExpansionEnclosures - nodeAEnclCount 2, nodeBEnclCount 2
Enclosure Check = Success

 

 

Zu den laufwerksbezogenen Prüfungen gehören:

  1. Die Appliance muss die korrekte Anzahl von NVRAM-Cachelaufwerken enthalten (die genaue Anzahl hängt vom Modell der Appliance ab). Empfohlene Maßnahme, wenn ein Fehler angezeigt wird: Suchen Sie nach fehlenden, fehlerhaften oder falsch eingesetzten NVRAM-Laufwerken. Die Ausgabe der "svc_diag list --nvme_drive" kann hilfreich sein.

 

  1. Die Datenlaufwerke im System müssen den offiziellen Konfigurationsregeln für SCM-, SCD- und SAS-Laufwerke folgen (in diesem Beispiel gibt es keine SCM-Laufwerke in der Appliance). Empfohlene Maßnahme, wenn ein Fehler angezeigt wird: Überprüfen Sie die Laufwerksbezeichnungen aller NVMe- und SAS-Laufwerke. Wenn SCM- und SSD-Laufwerkstypen gemischt sind, ersetzen oder entfernen Sie die Laufwerke nach Bedarf.

 

  1. Die gleiche Anzahl von Laufwerken muss von beiden Nodes sichtbar sein (ein Laufwerk, das nur von einem Node sichtbar ist, verursacht Probleme). Empfohlene Maßnahme, wenn ein Fehler angezeigt wird: Sie können "svc_diag list --nvme_drive" , um einen detaillierten Status zu NVMe-Laufwerken anzuzeigen, um zu ermitteln, welches Laufwerk oder welche Laufwerke nur auf einem Node sichtbar sind.

 

  1. Die gleiche Anzahl von Laufwerksgehäusen muss von beiden Nodes aus sichtbar sein (ein Gehäuse, das nur von einem Node sichtbar ist, verursacht Probleme). Empfohlene Maßnahme, wenn ein Fehler angezeigt wird: Überprüfen Sie alle Gehäusekabel und stellen Sie sicher, dass die Gehäuse ordnungsgemäß verkabelt sind.
checkIoms - nodeAIoms: [u' 303-321-000C', u' 313-202-000B']
checkIoms - nodeBIoms: [u' 303-321-000C', u' 313-202-000B']
Compare Node IOM Check = Success

 

Das I/O-Modul in jedem Steckplatz auf einem Node muss mit dem I/O-Modul im selben Steckplatz auf dem Peer-Node übereinstimmen.
 

Dies kann passieren, wenn der falsche Typ von I/O-Modul in einem Node vorhanden ist. Dies kann auch auftreten, wenn jeder Node ein I/O-Modul enthält, diese sich jedoch in unterschiedlichen Steckplätzen befinden (Beispiel: Steckplatz 0 auf einem Knoten, aber Steckplatz 1 auf dem Peer-Knoten). Sie können hier auch einen Fehler sehen, wenn ein I/O-Modul fehlt oder ausgeschaltet ist (siehe Abschnitt "Fehlerstatusregister" oben).


 

Empfohlene Maßnahme bei Fehlern:  Vergleichen Sie die Teilenummern der I/O-Module in beiden I/O-Modulsteckplätzen auf beiden Nodes. Wenn Inkonsistenzen vorliegen, verschieben oder ersetzen Sie I/O-Module nach Bedarf, um das Problem zu beheben. KB-Artikel 000125540 kann ebenfalls hilfreich sein.

OVERALL STATUS: True, return_code 0
IOM Consistency Check : Success
Node Consistency Check : Success
Battery Check : OK
Fault Status Register A : Success
Fault Status Register B : Success
Node A Accessible : True
Node B Accessible : True
Drive Check : Success
Node Drives Compare Check : Success
Enclosure Check : Success
IO Module Compare Check : Success

Dieser Abschnitt enthält eine Zusammenfassung der oben bereitgestellten Informationen.


Im Folgenden finden Sie ein Beispiel für eine erfolgreiche Ausgabe von " svc_diag_list --network" :

Beispielausgabe

***** Start minimal cabling check *****
OCP_MEZZ 0 is LINK_STATUS_UP on Node A
OCP_MEZZ 0 is LINK_STATUS_UP on Node B
OCP_MEZZ 1 is LINK_STATUS_UP on Node A
OCP_MEZZ 1 is LINK_STATUS_UP on Node B
***** Minimal cabling check: Overall errors: 0
Overall errors: 0, return code: 0

 

Affected Products

PowerStore
Article Properties
Article Number: 000139935
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  7
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