PowerStore: Das Hinzufügen einer Appliance zu einem vorhandenen Cluster schlägt mit "Unconfigured Faulted" fehl.
Summary: Während der Installation des Assistenten für die Erstkonfiguration (ICW) oder beim Hinzufügen einer Appliance zu einem vorhandenen Cluster schlägt die Aufgabe mit "Unconfigured Faulted" fehl ...
Symptoms
Während der Erstinstallation einer Appliance in einem neuen Cluster oder beim Hinzufügen einer neuen Appliance zu einem vorhandenen Cluster gibt es Hardware- und Netzwerkprüfungen, die fehlschlagen können. Dieser Fehler kann den Status der Appliance von "Unconfigured" zu "Unconfigured Faulted" ändern. Dieser Status bedeutet, dass die Appliance keinem neuen Cluster beitreten oder zu einem vorhandenen Cluster hinzugefügt werden kann. Der Fehler muss behoben werden, bevor die Appliance zu einem Cluster hinzugefügt werden kann.
Cause
Führen Sie die folgenden Schritte aus, um festzustellen, ob ein Hardware- oder Netzwerkproblem vorliegt, das den Zustand "Unconfigured Faulted" verursacht:
Resolution
Wenn Sie die Appliance zu einem vorhandenen Cluster hinzufügen (über PowerStore Manager):
- Greifen Sie mithilfe der Zugriffsmethode für den Service-LAN-Port auf das System zu (siehe PowerStore: Zugriff auf einen Node für Details).
- Sobald Sie sich beim Servicecontainer als Servicenutzer angemeldet haben, führen Sie das folgende Serviceskript aus, um festzustellen, ob ein Hardware- oder Netzwerkproblem vorliegt:
svc_diag list --icw_hardware svc_diag list --network - Wenn keine Fehler oder Probleme gemeldet werden, ist es möglich, dass die ursprünglichen Symptome, die während des ICW- oder des Appliance-Add-Vorgangs beobachtet wurden, vorübergehend waren.
- Wenn ein Fehler oder ein Problem angezeigt wird und Sie nicht bestimmen können, wie Sie es beheben können, führen Sie das folgende Skript aus, um eine Datenerfassung zu erstellen, und wenden Sie sich an Ihren Serviceanbieter, um Unterstützung zu erhalten:
svc_dc run - Wenn Sie eine Appliance in einem neuen Cluster installieren und die Installation wiederholen möchten:
- Schließen Sie Ihr Discovery Tool und/oder Ihren Browser.
- Starten Sie das Discovery Tool neu oder öffnen Sie den Browser mit der statischen Service-LAN-IP-Adresse für Node A [d. h. 128.221.1.252].
- Wenn das System anzeigt, dass es sich im Status "Unkonfiguriert" befindet, setzen Sie die Schritte für die Erstkonfiguration/den ICW fort
- Wiederholen Sie den Vorgang zum Hinzufügen der Appliance, um festzustellen, ob die Aufgabe erfolgreich war.
- Falls die Aufgabe weiterhin fehlschlägt, führen Sie eine Datenerfassung durch, um relevante Protokolle zu erhalten, und wenden Sie sich an Ihren Serviceanbieter, um Unterstützung zu erhalten.
Im Folgenden finden Sie ein Beispiel für eine erfolgreiche Ausgabe von " svc_diag list --icw_hardware " in der linken Spalte; Die rechte Spalte enthält Erläuterungen zu Fehlern, die möglicherweise angezeigt werden.
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Beispielausgabe |
Beschreibung |
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Diese Tabellen bestehen aus drei Spalten: Zusammenfassung | Name der vor Ort austauschbaren Einheit (FRU) | Statussensorwert
OK = FRU-Status ist gut.
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Bei diesen Prüfungen werden die Werte der FRU-Statuszusammenfassung von jedem Node verglichen. Es wird erwartet, dass beide Nodes denselben Zusammenfassungswert für jede FRU melden. Empfohlene Maßnahme bei Fehlern:
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Die Statuswerte in der linken Spalte sind OK oder FLT. Diese werden aus dem Fehlerstatusregister (FSR) gelesen.
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Zu den laufwerksbezogenen Prüfungen gehören:
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Das I/O-Modul in jedem Steckplatz auf einem Node muss mit dem I/O-Modul im selben Steckplatz auf dem Peer-Node übereinstimmen. Dies kann passieren, wenn der falsche Typ von I/O-Modul in einem Node vorhanden ist. Dies kann auch auftreten, wenn jeder Node ein I/O-Modul enthält, diese sich jedoch in unterschiedlichen Steckplätzen befinden (Beispiel: Steckplatz 0 auf einem Knoten, aber Steckplatz 1 auf dem Peer-Knoten). Sie können hier auch einen Fehler sehen, wenn ein I/O-Modul fehlt oder ausgeschaltet ist (siehe Abschnitt "Fehlerstatusregister" oben).
Empfohlene Maßnahme bei Fehlern: Vergleichen Sie die Teilenummern der I/O-Module in beiden I/O-Modulsteckplätzen auf beiden Nodes. Wenn Inkonsistenzen vorliegen, verschieben oder ersetzen Sie I/O-Module nach Bedarf, um das Problem zu beheben. KB-Artikel 000125540 kann ebenfalls hilfreich sein. |
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Dieser Abschnitt enthält eine Zusammenfassung der oben bereitgestellten Informationen. |
Im Folgenden finden Sie ein Beispiel für eine erfolgreiche Ausgabe von " svc_diag_list --network" :
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Beispielausgabe |
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