Dell NativeEdge: How to solve deployment error "Failed to download blueprint directory from endpoint."

Summary: In some deployments, the Ansible node is stuck providing the following error message: Failed to download blueprint directory from endpoint. Falling back to rest request. This article is intended to understand the error and fix the blueprint to make deployment working on. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During the deployment, you may encounter the following errors in the log:

 

error    nativeedge_log    Failed to download blueprint directory from endpoint. Falling back to rest request.

nativeedge_event    Task failed 'ne_ansible.tasks.run' -> [Errno 17] Output file 'name_ofthe_blueprint.zip' already exists: 'name_ofthe_blueprint.zip' [retry 2/60]

Cause

The reason behind this error is that the Ansible plugin is unable to compare its contents with what was already uploaded to the internals of EdgeOrchestrator. When the plugin tries to upload it once again (for example, having a second Ansible node_template inside this blueprint), it fails with this error.

The issue in the NativeEdge Ansible plugin is already logged for version 2.2.0.0 and fixed in the next releases starting from 3.0.0.0.

Resolution

To fix that, go to your working directory with the source code for a blueprint, or download the blueprint from Edge Orchestrator and extract it.

Navigate to go to the directory with the blueprint, using any terminal in Linux or Powershell for Windows.

For Linux run following command:

find /path/to/directory -type f -empty

For Windows run the following command:

Get-ChildItem -Path . -File -Recurse | Where-Object { $_.Length -eq 0 } | ForEach-Object {
    # Output the full path of the empty file
    $_.FullName
}

The output should provide you with list of empty files inside the blueprint.

Remove the empty files in any way that you like.

Rezip the blueprint and verify that the problem is solved.

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000256511
Article Type: Solution
Last Modified: 25 Apr 2025
Version:  2
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