SourceOne Email Management - Search-as from SourceOne websearch fails when SSO is enabled.

Summary: Search-as from SourceOne Web-Search fails when SSO is enabled.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upgraded to .NET Framework 4.7

Search-as from SourceOne websearch fails when SSO is enabled.

The websearch interface shows the following error: 

"You do not have  rights to search as this user. Access is denied." 

The EXSearchWebservice.log shows access is granted:

"User: x has full mailbox permissions to y"






Cause

.NET Framework is on an unsupported version, this issue has been observed on .NET Framework 4.7.

Resolution

Downgrade to known functioning version of .NET Framework 

1.  Uninstall .NET Framework 4.7
2.  Install .NET Framework 4.5 - 4.62
3.  Repair install ES1_WebServices
3.  Repair install ES1_Search
4.  Repair install ES1_Mobile
5.  Reconfigure SSO

Additional Information

Minimum .NET requirements can be found in the SourceOne Products Compatibility Guide. Current minimum requirement is (Microsoft .NET Framework 4.0 Redistributable Package.)
Article Properties
Article Number: 000168125
Article Type: Solution
Last Modified: 14 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.