PowerProtect Data Manager: T-SQL backup and recovery commands return 0 rows affected

Summary: T-SQL backup and recovery commands return 0 rows

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When backup or restore is initiated through Microsoft App Agent for Application Direct, the autogenerated T-SQL script completes successfully, however when a standalone T-SQL statement is written and performed, the backup or restore returns:
(0 rows affected)
There are no further details on why the operation fails.

Cause

During the installation of PowerProtect Data Manager on the SQL server, there is an optional parameter that enables the T-SQL statements to be performed as standalone.

Resolution

Reinstall the PowerProtect Data Manager SQL software. 
During installation, on the CLR assembly deployment wizard, select authentication option with Username and Password to deploy the CLR Assembly.
Backups and restore should now show that the log information and standalone T-SQL commands should perform.

Affected Products

PowerProtect Software
Article Properties
Article Number: 000217574
Article Type: Solution
Last Modified: 24 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.