NetWorker: Windows-client mislukt met "Het proces heeft geen toegang tot het bestand omdat het wordt gebruikt door een ander proces (Win32-fout 0x20))"

Summary: Windows-client mislukt met "Het proces heeft geen toegang tot het bestand omdat het wordt gebruikt door een ander proces (Win32-fout 0x20))"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De Windows-client kan geen back-up maken van bepaalde opslagsets en de volgende fout wordt weergegeven: "Het proces heeft geen toegang tot het bestand omdat het wordt gebruikt door een ander proces (Win32 error 0x20)"

Cause

Dit is geen NetWorker-fout, dit wordt aangegeven door de Windows OS-foutcode: (Win32 error 0x20)

0x00000020

ERROR_SHARING_VIOLATION

Het proces kan het bestand niet openen omdat het door een ander proces wordt gebruikt.


Zie het volgende Microsoft-document: Win32-foutcodes Deze hyperlink leidt u naar een website buiten Dell Technologies.

Resolution

Dit zou niet moeten gebeuren op clients waarop Volume Shadowcopy Service (VSS) is ingeschakeld. Om te controleren of VSS is ingeschakeld, opent u de clienteigenschappen vanuit de NetWorker Management Console (NMC). Zorg er onder Protection-Clients> in het tabblad Apps en modules in de clienteigenschappen voor dat het veld "Save Operations" niet het volgende bevat VSS:*=OFF
Bewerking opslaan om VSS uit te schakelen 
Als deze optie is ingesteld, verwijdert u deze.

Additional Information

Op de meeste standaard Windows bestandssysteemclients moet VSS niet worden uitgeschakeld. Dit mag alleen worden gedaan om problemen op te lossen om Windows VSS te identificeren als een andere oorzaak van een storing. Voor persistente VSS-fouten is Microsoft-support vereist voor hoofdoorzaak en oplossing.

Als het probleem niet is opgelost door VSS in te schakelen, of als u VSS niet wilt inschakelen, hebt u twee andere opties:

  1. Probeer de back-up van deze client te plannen tijdens een periode waarin de toegangsactiviteit op de back-up beperkt is.
  2. Gebruik NetWorker-richtlijnen om deze bestanden over te slaan, zodat de back-up niet op een storing wijst; Dit betekent echter dat er geen back-up van de gegevens wordt gemaakt. Deze oplossing is afhankelijk van het belang van de directories/bestanden die mislukken met dit bericht. Meestal treedt deze fout op bij .log- en .dat-bestanden. De NetWorker Command Reference Guide bevat informatie over richtlijnen. Support voor NetWorker | Handleidingen en documenten 


Bekijk het volgende voor meer informatie over VSS en het gebruik ervan: Volume Shadow Copy Service Deze hyperlink leidt u naar een website buiten Dell Technologies.

NetWorker: Problemen met back-ups oplossen als gevolg van VSS-problemen

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000031490
Article Type: Solution
Last Modified: 24 Oct 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.