NetWorker: Klient systemu Windows kończy się niepowodzeniem z komunikatem "Proces nie może uzyskać dostępu do pliku, ponieważ jest on używany przez inny proces (błąd Win32 0x20))"
Summary: Klient systemu Windows kończy się niepowodzeniem z komunikatem "Proces nie może uzyskać dostępu do pliku, ponieważ jest on używany przez inny proces (błąd Win32 0x20))"
Symptoms
Klient systemu Windows nie może wykonać kopii zapasowej niektórych zestawów zapisu i wyświetla się następujący błąd: "Proces nie może uzyskać dostępu do pliku, ponieważ jest on używany przez inny proces (Win32 error 0x20)"
Cause
Nie jest to błąd NetWorker, wskazuje na to kod błędu systemu operacyjnego Windows: (Win32 error 0x20)
|
|
Proces nie może uzyskać dostępu do pliku, ponieważ jest on używany przez inny proces. |
Zapoznaj się z następującym dokumentem firmy Microsoft: Kody błędów Win32
Resolution
Nie powinno się to zdarzyć na klientach, na których jest włączona usługa kopiowania woluminów w tle (VSS). Aby sprawdzić, czy usługa VSS jest włączona, otwórz właściwości klienta w konsoli NetWorker Management Console (NMC). W obszarze Protection-Clients> we właściwościach klienta na karcie Apps & Modules upewnij się, że pole "Save Operations" nie zawiera VSS:*=OFF
Jeśli ta opcja jest włączona, usuń ją.
Additional Information
Na większości standardowych klientów systemu plików systemu Windows usługa VSS nie powinna być wyłączona. Należy to zrobić tylko w celu rozwiązywania problemów w celu zidentyfikowania usługi VSS systemu Windows jako innej przyczyny awarii. Trwałe awarie usługi VSS wymagają zaangażowania pomocy technicznej firmy Microsoft w celu uzyskania głównej przyczyny i rozwiązania.
Jeśli włączenie usługi VSS nie rozwiąże problemu lub nie chcesz włączać usługi VSS, masz dwie inne opcje:
- Spróbuj zaplanować tworzenie kopii zapasowej klienta w okresie, gdy aktywność dostępu do tej kopii jest ograniczona.
- Użyj dyrektyw NetWorker, aby pominąć te pliki, aby kopia zapasowa nie wskazywała na awarię; Oznacza to jednak, że kopia zapasowa danych nie jest tworzona. To rozwiązanie zależy od ważności katalogów/plików, dla których ten komunikat kończy się niepowodzeniem. Zazwyczaj ten błąd występuje w plikach .log i .dat. Podręcznik informacyjny polecenia NetWorker zawiera informacje na temat dyrektyw. Wsparcie dla NetWorker | Instrukcje obsługi i dokumenty
Aby uzyskać więcej informacji na temat usługi VSS i jej zastosowań, zapoznaj się z następującymi kwestiami: Usługa kopiowania woluminów w tle
NetWorker: Rozwiązywanie problemów z kopiami zapasowymi z powodu problemów z usługą VSS