Avamar Gen4T -> A virtual disk shows Status: Impacted

Summary: The status of a virtual (logical) disk on a Gen4T node is being reported as "Impacted".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

admin@avamar:~/>: avsysreport vdisk
<..snippet..>
=== Virtual disks
Virtual Disk ID : 5
Status : Impacted
Layout : RAID-1
Size : 1.816 TB
Bus Protocol : <Undefined>
Media : Hard Disk Device
Access Policy : Not Applicable
Read Policy : Read Ahead
Write Policy : Write Back
IO Policy : Direct
Stripe Size : Not Applicable
Disk Cache Policy : Disabled
Number of Drives : 2
Device Name : Not Applicable


Both segments (hard drives) are present for a virtual disk.

Example:

admin@avamar:~/>: arcconf getconfig 1 ld 5 | egrep "Logical device number|Segment"
Logical device number 5
   Segment 0                                : Present (Controller:1,Enclosure:0,Slot:10)         ZC20RL1S
   Segment 1                                : Present (Controller:1,Enclosure:0,Slot:11)         ZC20RL4P

Cause

Unknown. It is possible that the internal controller reset with the code 0 caused this problem.

Resolution

Workaround:

1. Log in to the affected node as admin user.
2. Identify the drive impacted by the problem and note the Virtual Disk ID.
 

avsysreport vdisk | egrep "Virtual Disk ID|Impacted"


Sample output:

admin@avamar:~/>: avsysreport vdisk | egrep "Virtual Disk ID|Impacted"
Virtual Disk ID : 5
Status : Impacted


3. Verify that both segments for the virtual disk are present.
 

arcconf getconfig 1 ld <Virtual Disk ID> | egrep "Logical device number|Segment"

Where <Virtual Disk ID> is the Virtual Disk ID from step 2.

Example for the virtual drive with ID 5

admin@avamar:~/>: arcconf getconfig 1 ld 5 | egrep "Logical device number|Segment"
Logical device number 5
   Segment 0                                : Present (Controller:1,Enclosure:0,Slot:10)         ZC20RL1S
   Segment 1                                : Present (Controller:1,Enclosure:0,Slot:11)         ZC20RL4P


Note: Stop following this KB article if any of the segments is missing and create a Service Request with Dell|EMC Avamar Support.

4. Initiate a Verify with Fix for the virtual disk in question in order to verify the structure.
 

arcconf task start 1 logicaldrive <Virtual Disk ID> verify_fix

Where <Virtual Disk ID> is the Virtual Disk ID from step 2.

5. Check if the disk status changes to Build/Verify.
 

avsysreport vdisk vdisk=<Virtual Disk ID> | egrep "Virtual Disk ID|Status"

Where <Virtual Disk ID> is the Virtual Disk ID from step 2.

Sample output:

admin@avamar:~/>: avsysreport vdisk vdisk=5 | egrep "Virtual Disk ID|Status"
Virtual Disk ID   : 5
Status            : Impacted ( Build/Verify : 0 % )


6. Check the priority of the rebuild task and note the Task ID.
 

arcconf getstatus 1


Sample output of the rebuild task running at low priority


7. Set the task priority to high.

admin@avamar:~/>: arcconf getstatus 1
Controllers found: 1
Logical device Task:
Logical device                 : 5
Task ID                        : 101
Current operation              : Rebuild
Status                         : In Progress
Priority                       : Low
Percentage complete            : 0

 

arcconf setpriority 1 <Task ID> high

Where <Task ID> is the ID of the rebuild task from step 6.

8. Wait until the rebuild is completed and verify the virtual disk status.
 

avsysreport vdisk vdisk=<Virtual Disk ID> | egrep "Virtual Disk ID|Status"

Where <Virtual Disk ID> is the Virtual Disk ID from step 2.

Sample output:

admin@avamar:~/>: avsysreport vdisk vdisk=5 | egrep "Virtual Disk ID|Status"
Virtual Disk ID   : 5
Status            : Ok


9. Procedure complete
 

Affected Products

Avamar

Products

Avamar, Avamar Data Store Gen4T
Article Properties
Article Number: 000037521
Article Type: Solution
Last Modified: 14 Apr 2025
Version:  4
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