TPM option is missing in the system BIOS setup Latitude, Precision, or XPS

Summary: The Trusted Platform Module (TPM) option may be missing in the system BIOS setup or Windows Operating System on your Dell Latitude, Dell Precision, or XPS system. Follow the stepsSee more

Article Content


Symptoms

No symptom information.

Cause

No cause information.

Resolution

TPM 2.0 missing

You may encounter a situation where the Trusted Platform Module (TPM) 2.0 option is missing from the BIOS setup screen, the Security option, or that there is no TPM present when running the Trusted Platform Module Microsoft management console (TPM.msc) in Windows.


This issue may become apparent as the result of a BitLocker recovery message.

 
Note: This only applies to platforms that support or can be switched to TPM 2.0. (Skylake and Newer systems.)


On computers with encrypted hard drives installed, you may also experience a no-boot situation if the TPM option is missing. Check the BIOS settings to ensure that TPM isn't missing. Also follow the steps below to resolve the missing TPM issue if a no-boot occurs on an encrypted hard drive.


Solution

Note: Dell recommends that the entire installation base of applicable systems be updated, not just systems that are presenting issues with TPM.


If you are using UEFI boot mode, it is recommended to download and install the latest TPM 2.0 firmware version from the Dell Support Website/Drivers & downloads on your applicable systems. The firmware is located under the Security category in the list of drivers. This new TPM 2.0 firmware should prevent this issue from occurring in the future.


If using Legacy boot mode, download and install the latest TPM 1.2 firmware version from the Dell Support Website/Drivers & downloads on your applicable systems. The firmware is located under the Security category in the list of drivers.

   
Note: Search for drivers on the Dell Support Website by system model, not the service tag, as depending on the service tag entitlement, the TPM firmware files may not be displayed.


If TPM is not present, please try the following troubleshooting steps:

 
  1. Update the system BIOS to the latest version available on the Dell Support Website/Drivers & downloads.
  2. Power off the system then disconnect the AC power cord and leave the system unplugged for about 30 s.
  3. Reconnect AC power to the system and boot to the BIOS setup using the F12 one time boot menu.
    Note: To make sure TPM is turned on, you must press F2 to enter System Setup. Then go to the Security section and check that TPM is set to On under the TPM security settings.
  4. If TPM is restored, continue with normal system operation.
  5. If TPM is still missing from BIOS setup, please contact Technical Support for further assistance.
 

Article Properties


Affected Product

Latitude

Product

Mobile Workstations

Last Published Date

09 Apr 2021

Version

4

Article Type

Solution

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