RecoverPoint for Virtual Machines: Error: Failed to diagnose cluster XXXXXXXXXX Received During a Non-Disruptive Upgrade

Summary: RecoverPoint for Virtual Machines: Error: Failed to diagnose cluster XXXXXXXXXX Received During a Non-Disruptive Upgrade.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upgrading a RecoverPoint for Virtual Machines cluster 5.1.1.x to 5.1.1.x fails with the error, "Failed to diagnose cluster XXXXXXXXXXXX," during the precheck processes in Deployer.

With the RecoverPoint clusterLogic log:

2018/07/01 20:53:45.900 [http-bio-443-exec-11] (ExceptionUtils.java:47) ERROR - Error: Failed to diagnose cluster XXXXXXXXX.  com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException:
Failed to diagnose cluster XXXXXXXXX. com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.SocketTimeoutException: connect timed outCaused by: java.net.SocketTimeoutException: connect timed out.

DEBUG - VerifyLegalUpgradeTask: Start running task: Verify legal upgrade. with params: ALLOW_SAME_VERSION_UPGRADE  BaseFapiAdapter.java:93)

2018/07/01 20:49:47.738 [http-bio-443-exec-11] (BaseFapiAdapter.java:93) ERROR - initConnection - failed to get current user information:com.sun.xml.ws.client.ClientTransportException: The server sent HTTP status code 404: Not Found

 

Cause

Cluster logic picks the incorrect vRPA to send FAPI requests for in order to run cluster diagnostics to ensure that the environment is free of potential issues. vRPAs 3 through 8, if this exists in a system, do not have FAPI running on them, causing this situation to occur. Only vRPAs 1 and 2 have FAPI available and running which is responsible for sending the requests for cluster diagnostic information.

 

Resolution

Resolution:
This issue is addressed in the RecoverPoint for Virtual Machines 5.2.0.1 version.

A solution exists for this issue prior to 5.2.0.1, but intervention from Dell technical support personnel is required. RecoverPoint support requires root access to resolve this situation. Contact the Dell Customer Support Center or your service representative for technical support and reference this Dell knowledgebase solution ID.

 

Affected Products

RecoverPoint for Virtual Machines

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000167707
Article Type: Solution
Last Modified: 19 Sept 2025
Version:  4
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