NetWorker: Active Directory Users are Unable to Log in or Access NetWorker Management Console With Their Credentials. Error Message "username or password is incorrect"

Summary: Active Directory users are unable to log in or access the NetWorker Management Console (NMC) with their credentials. The error message received is "username or password is incorrect."

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Symptoms

Active Directory users are unable to log in or access the NetWorker Management Console (NMC) with their credentials.

nsrlogin is failing for the Active Directory user with the error: 
username, or password is incorrect
The following command returns the error message:
authc_mgmt -u administrator -p <password>  -e query-ldap-groups-for-user -D query-tenant=<tenant name> -D query-domain=<domain name> -D user-name=<user name>

ERROR [main] (DefaultLogger.java:222) - Error while performing Operation:
com.emc.brs.auth.common.exception.BRHttpErrorException: 404 . Server message: A user with the name <user name>  does not exist in authority <Authority name> at com.emc.brs.auth.client.template.impl.DefaultBRResponseErrorHandler.handleError(DefaultBRResponseErrorHandler.java:65) ~[auth-cli-with-dependencies.jar:?]

Cause

The external authority is configured to search for the users and groups only at the root domain level.

Resolution

  1. Update the external authority configuration. Change the following lines in:
/opt/nsr/authc-server/scripts/authc-create-ad-config.sh.

From :
authc_config -u administrator -p <password> -e add-config \
-D "config-search-subtree=n" \

To:
authc_config -u administrator -p <password> -e update-config \
-D "config-search-subtree=y" \

All other properties and values in the script remain the same. For more details on authc scripting, see Dell article 15832: NetWorker: How To Set up LDAP/AD using authc_config scripts
  1. Save the changes.
  2. Run the script:
authc-create-ad-config.sh
  1. Retry the nsrlogin command:
nsrlogin -t <tenant_name> -d <domain_name> -u <ad_username>
Article Properties
Article Number: 000216733
Article Type: Solution
Last Modified: 06 Oct 2023
Version:  2
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