Dell Unity : La définition d’une bannière personnalisée avec svc_banner échoue avec une erreur d’autorisation

Summary: Les utilisateurs qui suivent la procédure de définition d’une bannière personnalisée à l’aide de la commande svc_banner, comme décrit dans les Fiches techniques sur les commandes de service de la gamme Dell Unity, rencontrent des erreurs d’autorisation. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les utilisateurs qui suivent la procédure pour définir une bannière personnalisée à l’aide de l’option svc_banner comme décrit dans les notes techniques sur les commandes de maintenance de la gamme Dell Unity (pages 6 et 7) se heurtent à des erreurs d’autorisation.

Conformément à la documentation, il est conseillé aux utilisateurs de placer le fichier texte du modèle personnalisé dans le fichier /home/service directory et lorsqu’ils tentent de le faire, ils reçoivent une erreur de refus d’autorisation. 

Capture d’écran du message d’autorisation refusée

Cause

C’est comme prévu. 
La commande /home/service Le répertoire n’est accessible que par les utilisateurs qui ont injecté root.

Resolution

Les utilisateurs doivent plutôt utiliser la commande /home/service/user Répertoire accessible à l’utilisateur du service et qui ne nécessite pas d’accès root.
  1. Création de fichiers texte dans le répertoire /home/service/user Répertoire dont le contenu localisé est nommé :
    • Pourl’anglais : en_US.txt
    • Pour le biélorusse : be_BY.txt
    • Pour le chinois :zh_CN.txt
  2. Pour appliquer ces fichiers, exécutez la commande suivante en tant qu’utilisateur de maintenance :
svc_banner --put en_US.txt be_BY.txt zh_CN.txt
Si vous êtes connecté à Unisphere, déconnectez-vous, puis reconnectez-vous. La nouvelle bannière doit s’afficher. 

Exemple : 

Capture d’écran de la sortie de commande
Capture d’écran de la bannière de test
 
 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000219224
Article Type: Solution
Last Modified: 16 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.