NMM Active Directory 粒度备份失败并显示身份验证错误;客户端凭据太弱

Summary: NetWorker Module for Microsoft (NMM) 手动备份 Active Directory 失败。 备份失败并显示身份验证错误; 客户端凭据太弱。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Microsoft (NMM) 手动备份 Active Directory 失败。   

  • 命令示例 - 此命令从命令行运行
nsradsave -b "PoolName" -s ServerName  -D 9  -l full "DC=amer,DC=lan"

 

输出示例 
 

C:\Program Files\EMC NetWorker\nsr\applogs>nsradsave -b dd1amerlan -s linux1 -l full "CN=users,DC=amer,DC=lan"

89613:(pid 3080): Unable to initialize SSL library: BSAFE FIPS library path was not set
200170:(pid 3080): unable to initialize multisubnet state: Authentication error; why = Client credential too weak
145072:(pid 3080): Unable to get port range from local nsrexecd: Failed to initialize ports using nsrexecd on dc.amer.lan: Authentication error; why = Client credential too weak
107092:(pid 3080):Version information for C:\Program Files\EMC NetWorker\nsr\bin\nsradsave.exe: Original file name: nsradsave.exe    
   Version: 19.11.0.17     Comments: Supporting Microsoft Volume Shadow Copy Service
53362:(pid 3080): Cannot start session with server linux1: Authentication error; why = Client credential too weak
Could not obtain root entries
Failed to initialize backup.
Authentication error; why = Client credential too weak

 

Cause

此问题的根本原因是客户端启动的(手动)备份存在已知限制。  

  • 当 NetWorker 服务器和客户端在 NSRLA“auth methods”中都有 nsrauth 时,会发生这种情况,例如:
auth methods:  "0.0.0.0/0, nsrauth"
  • 如果 NetWorker 服务器是 linux 并且仅使用 nsrauth,则也会发生这种情况

 

Resolution

NMM 管理指南中记录了此限制。

支持的 Active Directory 备份和恢复类型及配置

NMM 支持:
● 粒度备份,可在完整和增量级别执行。
● 粒度恢复,即单个 Active Directory 对象或对象属性的恢复。

说明:要备份和恢复文件系统,以及恢复系统状态备份,请使用 NetWorker。

说明:对于成功的客户端启动备份,请将 NMM 客户端中的身份验证方法更改为身份验证方法:

0.0.0.0/0,nsrauth/oldauth。

 

Article Properties
Article Number: 000200776
Article Type: Solution
Last Modified: 20 Jan 2026
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.