Selže obnovení samostatného virtuálního počítače NetWorker Module for Microsoft Hyper-V

Summary: NetWorker Module for Microsoft Hyper-V Standalone Virtual Machine Restore from UI Vytvoření cílové cesty se nezdařilo.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 V samostatném nastavení technologie Hyper-V:

Obnovení virtuálního počítače z jednoho serveru Hyper-V na jiný selhalo s následující chybou:

nsrnmmrc: 06/23/25 19:03:29.986376 nsrnmmrc-D3 expand_registry_path: input G:\VM_NAME\VM_NAME-VHHDX_ID-DISKNAME.vhdx
127955 23/06/2025 19:03:29 Failed to create directory G:\VM_NAME: No such file or directory
0 23/06/2025 19:03:29 Failed to create destination path for ' G:\VM_NAME\VM_NAME-VHHDX_ID-DISKNAME.vhdx'

nsrnmmrc: 06/23/25 19:03:30.075410 nsrnmmrc-D3 Successfully closed the recover session.
0 23/06/2025 19:03:30 Failed to complete BBB restore with error Failed to create destination path for ' G:\VM_NAME\VM_NAME-VHHDX_ID-DISKNAME.vhdx'


175686 23/06/2025 19:03:32 Restore failed with the error: Failed to complete BBB restore.
0 23/06/2025 19:03:32 Post restore files - nothing to do.
177924 23/06/2025 19:03:32 Fatal error during restoring files for Virtual Machine VS605 with savetime -- <SaveTime>.
71234 23/06/2025 19:03:37 **************************************************************


71238 23/06/2025 19:03:37 Recover completion status
50247 23/06/2025 19:03:37 Unable to restore files for VS605 with error: Failed to complete BBB restore. and error code: 0x80004005.

56473 23/06/2025 19:03:37 **************************************************************

Na kartě NetWorker Module for Microsoft User Interface Monitor se zobrazují nastavení vybraná při obnovení.

Disk virtuálního počítače se pro stejný disk přidá dvakrát.

Hyper-V virtual machine recovery options:
          Source Hyper-V Server:<Source Hyper-V Server name>
          Destination Hyper-V Server: <Destination Hyper-V Server name>
          Destination path for the Hyper-V virtual machine configuration files: <Recovery directory>
          Destination path for the virtual machine:
               VM_NAME, G:\VM_NAME\VM_NAME-VHHDX_ID-DISKNAME.vhdx = < Recovery Directory>
                VM_NAME, G:\VM_NAME\VM_NAME-VHHDX_ID-DISKNAME.vhdx = < Recovery Directory>
          Host, on which the recovery process is run: <Destination Hyper-V Server name>

K tomu dochází pouze u obnovení samostatného virtuálního počítače Hyper-V z přírůstkových záloh:

Obnovení samostatného virtuálního počítače Hyper-V z úplných záloh funguje správně.

Obnovení virtuálních počítačů clusteru Hyper-V funguje správně.

Cause

 V samostatném nastavení technologie Hyper-V:

V případě úplné zálohy se zobrazuje jenom jedna položka vhdx na disk a obnovení z jednoho serveru Hyper-V na jiný funguje správně.

V případě přírůstkového zálohování se zobrazí duplicitní položky vhdxs pro každý disk a obnovení z jednoho serveru Hyper-V na jiný selže. 

Kontrola indexu klienta pomocí následujícího příkazu:

nsrinfo -vvv -n all <Hyper-v Server Name> > c:\nsrinfo.txt

Výstup přírůstkového zálohování zobrazuje duplicitní položky:

  
VSS file
  Entry type: 8
  Usage type: 0
  Flags: 0
  Component name: ABC....
  Saveset name: APPLICATIONS:\Microsoft Hyper-V\VMNAME\<VHDX_ID>
  Cover savetimes: <savetime>
  Backup Level: full
  Application Attributes: 
    *NSR_BACKUP_GENERATIONID: 1751568752;
                  ListOfVHDs: "VMNAME.vhdx,";
              NSR_RCT_BACKUP: TRUE;
           NSR_SAVESET_COUNT: 1;
           NSR_SAVESET_INDEX: 0;
      NSR_SNAPSHOT_SESSIONID: 
da_dirl->G:\VMNAME\VMNAME\Virtual Hard Disks\VMNAME.vhdx
da_dirl->G:\VMNAME\VMNAME\Virtual Hard Disks\VMNAME.vhdx
WIN ASDF v2 file `APPLICATIONS:\Microsoft Hyper-V\VMNAME\', NSR size=xxx, date=<savetime> <backup_time>, file size=0

Resolution

Jedná se o známý problém a oprava sloučená do verzí 19.11.0.4 a 19.12.0.1. nebo novějších verzí.

Affected Products

NetWorker Module for Microsoft
Article Properties
Article Number: 000345691
Article Type: Solution
Last Modified: 20 Jan 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.