AppSync: Appsync-backup.bat v režimu ladění Přestal jsem odpovídat se zprávou: Vytvoření adresáře Keycloak se nezdařilo.
Summary: Appsync-backup.bat v režimu ladění může přestat reagovat se zprávou: Vytvoření adresáře keycloak se nezdařilo: C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Jakákoli funkce, která provádí zálohování databáze AppSync, může přestat reagovat, pokud na disku, který produkt používá k instalaci, existuje některá z těchto složek.
Spuštění appsync-backup.bat ze <složky install dir>\backup-assistant v režimu ladění, například:
Počítač přestane reagovat s následující chybou za předpokladu, že "C" byla instalační jednotka:
\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox \EMC\AppSync\jboss\datastore\data\AppSync_Keycloak \EMC\AppSync\jboss\datastore\data\configFiles \EMC\AppSync\jboss\datastore\data\AppSync_Ese \EMC\AppSync\jboss\datastore\data\AppSync_LIC
appsync-backup -d
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Cause
Appsync-backup.bat spuštěný v databázi, která nemá definované pole, o kterém je známo, že přestalo reagovat pro AppSync 4.4 a novější, ponechá následující složky na místě (za předpokladu, že instalační jednotka je C:):
To způsobí, že následná spuštění nástroje appsync-backup.bat, i když jsou spuštěna ze své podstaty během upgradů, přestanou reagovat. Při ručním spuštění v režimu ladění se však zobrazí chyba:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak C:\EMC\AppSync\jboss\datastore\data\configFiles C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Resolution
Odstraňte následující složky:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak C:\EMC\AppSync\jboss\datastore\data\configFiles C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Products
AppSyncArticle Properties
Article Number: 000200777
Article Type: Solution
Last Modified: 14 May 2026
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.