Powerpath: Migration enabler 6.2-during PPME handle setup IO increases across all source disks
Summary: PPME migration seems to have hung Disk Management and PowerPath 6.2 on the B node of an Active/Active cluster. Node A is the one that has 10 handles setup (no sync yet) but node B is showing high I/O across all disks for some reason. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Used diskpart and cmd prompt instead during the PPME migration
High IOs seen on Node B of the cluster while PPME session was set on Node A of the cluster
IO increases across the disks during the PPME handle setup stage, once the PPME handles are cleaned with powermig cleanup, IO normalizes on the disks.
Additionally customer is unable to access Disk Management when PPME is initiated, without a hang.
cluster.txt logs
000012c8.00002818::2017/10/06-04:12:49.647 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
000012c8.00001b34::2017/10/06-04:12:49.647 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.000025bc::2017/10/06-04:12:49.663 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000025bc::2017/10/06-04:12:49.663 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000025bc::2017/10/06-04:12:49.663 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring..
..............
000012c8.00001ac4::2017/10/06-04:22:19.480 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000003a0::2017/10/06-04:22:19.495 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.00001104::2017/10/06-04:22:19.495 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
000012c8.000003a0::2017/10/06-04:22:19.511 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.000025bc::2017/10/06-04:22:19.526 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
Status 21 in the above logs means The device is not ready.
000012c8.00001ac4::2017/10/06-04:22:19.480 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000003a0::2017/10/06-04:22:19.495 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
High IOs seen on Node B of the cluster while PPME session was set on Node A of the cluster
IO increases across the disks during the PPME handle setup stage, once the PPME handles are cleaned with powermig cleanup, IO normalizes on the disks.
Additionally customer is unable to access Disk Management when PPME is initiated, without a hang.
cluster.txt logs
000012c8.00002818::2017/10/06-04:12:49.647 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
000012c8.00001b34::2017/10/06-04:12:49.647 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.000025bc::2017/10/06-04:12:49.663 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000025bc::2017/10/06-04:12:49.663 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000025bc::2017/10/06-04:12:49.663 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring..
..............
000012c8.00001ac4::2017/10/06-04:22:19.480 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000003a0::2017/10/06-04:22:19.495 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.00001104::2017/10/06-04:22:19.495 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
000012c8.000003a0::2017/10/06-04:22:19.511 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.000025bc::2017/10/06-04:22:19.526 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
Status 21 in the above logs means The device is not ready.
000012c8.00001ac4::2017/10/06-04:22:19.480 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.00001104::2017/10/06-04:22:19.495 ERR [RES] Physical Disk: Failed to get snapshot info for disk, status 21. Ignoring...
000012c8.000003a0::2017/10/06-04:22:19.495 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
Cause
Accessing disk management during a PPME handle setup
Resolution
As a part of workaround can use diskpart commands and try performing different task using diskpart,
With above workaround wont blocked by the disk management hang
Additional Information
Customer was able to run the diskpart commands and successfully performed the PPME migration.
Server Manager was unusable during the duration of the PPME handle setup and PPME handle sync, so wasn't able view the event log or view Disk Manager
It is not yet clear what was the cause of the issue and PP Engineering is looking into the issue.
Server Manager was unusable during the duration of the PPME handle setup and PPME handle sync, so wasn't able view the event log or view Disk Manager
It is not yet clear what was the cause of the issue and PP Engineering is looking into the issue.
Affected Products
Storage NetworkingArticle Properties
Article Number: 000050087
Article Type: Solution
Last Modified: 04 Nov 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.