IP-Adresse des DCNM-Servers geändert

Summary: Nach dem Ändern der Server-IP funktioniert DCNM nicht mehr. In diesem Artikel erfahren Sie, wie Sie DCNM wieder zum Laufen bringen.

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Symptoms



Problem: Nach dem Ändern der Server-IP an der NIC kann sich DCNM nicht mehr anmelden.

DCNM wird weiterhin gestartet, aber bei der Anmeldeaufforderung muss die ursprüngliche DCNM-Server-IP eingetragen sein. 
Selbst wenn Sie die IP-Adresse hier in die neue ändern, schlägt die DCNM-Anmeldung fehl.


kA2j0000000kDSJCA2_3_0

In diesem Artikel erfahren Sie, wie Sie DCNM wieder zum Laufen bringen. Es gibt verschiedene Möglichkeiten, dies zu tun, abhängig von Ihrer DCNM-Version.

Cause

Sobald die Server-IP geändert wurde, werden die Konfigurationsdateien für DCNM nicht selbst aktualisiert und DCNM versucht ständig, die ursprüngliche IP zu verwenden, die nicht mehr anwendbar ist.

Resolution

DCNM 5.2(x) und früher: 

Im Cisco DCNM 5.2(x) Fundamentals Guide
Gehen Sie folgendermaßen vor, um die IP-Adresse eines Cisco DCNM-SAN-Servers zu aktualisieren:
        1. Beenden Sie den Cisco DCNM-SAN-Server.
        2. Ändern Sie den folgenden Parameter in der Datei $INSTALLDIR/conf/FMServer.conf .
            
wrapper.app.parameter.4=neue-Server-IP-hier
3. Anmelden Ändern Sie den folgenden Parameter in der Datei $INSTALLDIR/conf/server.properties .
            
server.bindaddrs = neue-server-IP-hier
4. Anmelden Geben Sie den folgenden Befehl ein, um die neue IP-Adresse tatsächlich zuzuweisen:
            
Führen Sie $INSTALLDIR/bin/PLMapping.bat -p newipaddress 0
aus. (Angenommen$INSTALLDIR ist das oberste Verzeichnis der DCNM-SAN-Installation. Der obige Befehl gilt für einzelne Serverinstanzen [kein Verbund], wobei 0 die Server-ID ist.)
Wenn dies nicht funktioniert, sowie wenn Sie
DCNM 5.2(x) und höher müssen Sie DCNM vollständig deinstallieren und eine Neuinstallation durchführen. Sie könnten auch versuchen, die PLMapping-Datei zu finden, und darauf doppelklicken, um zu versuchen, sie manuell neu zu installieren (ohne die 1. zu deinstallieren), aber die Installation funktioniert möglicherweise nicht auf diese Weise.
 
Anweisungen für eine saubere DCNM-Installation unten:

Aus dem Cisco DCNM 5.x – Grundlagenhandbuch für Windows:
        1. Stellen Sie sicher, dass die IP-Adresse des Cisco DCNM-Servers statisch zugewiesen ist.
        2. Installieren Sie den Cisco DCNM-Server unter "Programme und Funktionen" neu und wählen Sie, falls verfügbar, die Option "Vollständige Neuinstallation" aus, mit der Sie die Server-IP-Adresse während der Installation erneut angeben können.
        3. Melden Sie sich beim Cisco DCNM-Client an und geben Sie die neue IP-Adresse des Cisco DCNM-Servers im Feld DCNM-Server des Anmeldedialogfelds an. Möglicherweise wird immer noch die ursprüngliche IP-Adresse angezeigt, also ändern Sie sie einfach in die neue, und schon sind Sie fertig!

Im Cisco DCNM 5.x-Installationshandbuch für Linux (RHEL):
        1. Vollständige Neuinstallation Installiert den Cisco DCNM-Server und den Cisco DCNM-Client-Download-Service neu. (Es ist kein Neuinstallationstyp verfügbar, mit dem Sie den Installations- oder Archivordner ändern können.) *Wenn Sie RHEL verwenden und die IP-Adresse des Cisco DCNM-Servers ändern, müssen Sie auch die IP-Adresse im Skript INSTALL_DIR/bin/stopDCNM.sh manuell ändern.*

Hinweis: Wenn Sie die Webserver-Portnummer während der Installation ändern, wirkt sich dies auf die URL aus, die Cisco DCNM-Nutzer zum Herunterladen des Cisco DCNM-Clients verwenden.
Hinweis: Wenn Sie den Namensserviceport ändern, wirkt sich dies auf den Port aus, den Cisco DCNM-Nutzer angeben, wenn sie sich beim Cisco DCNM-Client anmelden.

Affected Products

Connectrix

Products

Connectrix, Connectrix MDS-Series Software
Article Properties
Article Number: 000064785
Article Type: Solution
Last Modified: 28 Mar 2024
Version:  3
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