Échec de l’envoi de l’enregistrement de l’agent DPA - Code d’erreur 12175

Summary: Échec de l’envoi de l’enregistrement de l’agent DPA : code d’erreur 12175. Le problème a commencé à se produire après l’application de la mise à niveau du correctif de sécurité Windows. La solution de contournement consiste à désactiver SSL dans le fichier dpaagent_config.xml de l’agent afin de rétablir les collectes de données ...

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Symptoms



L’agent DPA ne parvient pas à s’enregistrer auprès du serveur DPA.
 
Le message d’erreur suivant est consigné dans le journal de l’agent DPA :
ERR 6552.8236 20160728:114045 com.http - httpSendRequest() : Échec de l’envoi de la demande à https://127.0.0.1:9002/dpa-api/agent/registration : 12175
ERR 6552.8236 20160728:114045 agent.config - initAgentConfig() : L’enregistrement de l’agent auprès du serveur a échoué. En attente de réessayer...
 
Il s’agit de l’agent résidant sur le serveur d’application.
 
Le problème a commencé à se produire après l’application de la mise à niveau du correctif de sécurité Windows.
 
Il semble que le correctif de sécurité Windows ait eu un impact sur la bibliothèque SSL au niveau du système d’exploitation sur le serveur d’applications, ce qui a empêché l’agent d’application de s’enregistrer auprès du serveur d’applications et les données collectées n’ont pas pu être envoyées au serveur.
 
Lorsque nous avons essayé d’utiliser l’URL d’enregistrement de l’agent à l’aide de la https://127.0.0.1:9002/dpa-api/agent/registration de connexionsécurisée, il nous a semblé qu’Internet Explorer ne pouvait pas afficher la page Web, mais lorsque nous avons essayé la connexion non sécurisée http://127.0.0.1:9004/dpa-api/agent/registration nous avons été invités à saisir les informations d’identification avec succès.
 
L’agent ne peut pas se connecter au serveur d’applications sur une connexion sécurisée comme il l’était avant l’application du correctif de sécurité Windows et se connecte désormais au serveur d’applications uniquement sur une connexion non sécurisée.

Cause

La cause de ce problème n’est pas connue pour le moment.

Resolution

Ce problème n’a pas encore été résolu.
 
Solution de contournement :
 
Désactivez SSL dans le fichier dpaagent_config.xml de l’agent afin de rétablir les collectes de données.

1. Définissez les lignes suivantes sur le fichier dpaagent_config.xml sous <le dossier Install_dir>\agent\etc sur l’hôte de l’agent :
<SERVERPORT>9004</SERVERPORT>
<SERVERSSL>false</SERVERSSL>

2. Redémarrez les services de l’agent pour que les modifications prennent effet.

Pour plus d’informations ou de précisions, veuillez contacter le support technique EMC.

Affected Products

App Direct File System Agent
Article Properties
Article Number: 000065120
Article Type: Solution
Last Modified: 06 May 2025
Version:  3
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