ECS:GeoDriveエラー12175 - SSLライブラリーのロード中にアプリケーションで内部エラーが発生しました
Summary: GeoDrive - ECSからのエラー - 12175 - SSLライブラリーのロード中にエラーが発生しました |アプリケーションでSSLライブラリのロード中に内部エラーが発生しました |インストールがありません。
Symptoms
お客様から報告12175 - アプリケーションで SSL ライブラリのロード中に内部エラーが発生しました。
解決策については、『Dell EMC® GeoDrive™ for Windowsバージョン2.0ユーザー ガイド』を参照してください
メモ:
調査を開始する前に、ホスト接続の詳細設定で[許可されたHTTPSプロトコル]を確認してください
「アプリケーションでSSLライブラリのロード中に内部エラーが発生しました」という同じエラーメッセージが表示されることがあります。これは、ホストの詳細接続設定で「SSL 2.0」と「SSL 3.0」がオンになっている場合に発生する可能性があります
これらの設定はデフォルトでは有効になっていませんが、誤って有効になっている可能性があります
設定を確認するには、次の手順を実行します。
- 上部バーの[Hosts]をクリックします。
- ホストを選択し、[Edit]をクリックします。
- [詳細設定]タブを選択します
次の図は、「SSL 2.0」と「SSL 3.0」のデフォルト設定をチェックマーク が付いていない 状態を示しています
チェックマークが付いている場合は、チェックを外して「SSL 2.0」と「SSL 3.0」を無効にし、再度接続をテストしてみてください。
クラウド サーバー証明書をインストールしています
次のような12175セキュリティ エラー メッセージが表示された場合: 「サーバーの証明書を生成した認証局に不明な機能です」と表示される場合は、次のようにサーバーの証明書をGeoDriveクライアントにインストールします。
1.[Test(テスト)]をクリックすると、GeoDriveにセキュリティ エラー メッセージが表示され、証明書の詳細も示されます
2.ホスト名がサービス プロバイダーから提供された名前と同じであることを確認します。また、ホスト/ IPフィールドはサーバー構成中に入力されます(3ページの表11を参照)。正しくない場合は、サービス プロバイダーに正しい名前を確認してから続行してください。必要に応じて、誤ったホスト名を削除し、[Host/IP]フィールドに正しい名前を入力し、[Add]、[Test]の順にクリックします
3.成功のダイアログが表示されれば、この手順は完了です。クラウドとの接続は、GeoDriveのメイン ページに緑色のアイコンで示されます
4.同じエラー メッセージが再度表示された場合は、[ インストール]をクリックします。GeoDriveによってローカル コンピューターにSSL証明書がインストールされ、正常に完了したことを示すメッセージが表示されます。
5.「OK」をクリックします。サーバーとの安全な接続は、GeoDriveのメイン ページに緑色のアイコンで示されます。
Windows 2016 Serverでは、クリック インストール オプションは表示されません。
Cause
Windows 2016では、サーバー強化機能がレジストリセット(
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002
すでに存在するため、ソフトウェアは「別の」キーのインストールを要求します。それはすでにそこにあるからです:
Resolution
通常のインストールでは、サーバー強化機能のレジストリキーはありません。
したがって、解決策は、レジストリで次のキーを見つけることです:
"HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002"、それを削除(または名前変更)します。これで問題は解決されます。これで、SSL証明書を使用して、影響を受けるサーバーに証明書をインストールできます。
Additional Information
見る:WinHTTPログをキャプチャしています
WinHTTP ログは、WSDAPI アプリケーションのトラブルシューティングに役立ちます。これは、メタデータの交換に失敗した場合や、SSL/TLSネゴシエーションに失敗した場合に役立ちます
この手順では、クライアント コンピューターでWinHTTPログをキャプチャする方法を示します。ログ記録が有効になっている場合は、WSDAPI ベースのクライアント アプリケーションを実行しないでください。ログ記録が有効になっているときにクライアント アプリケーションが実行されている場合は、WS-Discovery の前にクライアントとコンピューターを再起動する必要があります。メタデータ交換トラフィックがWinHTTPログに表示されます。
WinHTTPログを収集するため。
- クライアント コンピューターで管理者特権のコマンド プロンプト ウィンドウを開きます。
- 次のコマンドを実行します: netsh winhttp set tracing trace-file-prefix="C:\Temp\dpws" level=verbose format=ansi state=enabled max-trace-file-size=1073741824
- このコマンドは、WinHTTP ログを有効にします。すべてのログファイルは C:\Temp ディレクトリに保存され、ファイル名は dpws プレフィックスで始まります。最大1 GBのログ ファイルが格納されます。
- クライアントでWinHTTPを使用するプロセスがすでに実行されている場合は、コンピューターを再起動します。たとえば、関数検出 API を使用している場合は、コンピューターを再起動する必要があります。関数検出 API は、トレースが有効になったときに既に開始されている可能性があるサービス ホスト内から WinHTTP を呼び出します。
- WSDAPI ベースのクライアント アプリケーションを起動します。デバッグ中のアプリケーションがデバッグされているか、WSD デバッグ クライアントを使用できます。
- アプリケーションの障害を再現します。
- WSDAPI ベースのクライアント アプリケーションを終了します。
- WinHTTP を使用するプロセスがクライアント アプリケーションで終了しない場合は、コンピューターを再起動します。たとえば、関数検出 API を使用している場合は、コンピューターを再起動する必要があります。
- 次のコマンドを実行します: netsh winhttp set tracing state=disabled
- このコマンドは、WinHTTPログを無効にします。
- C:\Temp の DPWS ログを調べ、必要な要求とメッセージが送信されたことを確認します。
- セキュア チャネル(HTTPS)通信を使用している場合は、SSL/TLS障害を確認します。
WinHTTP ログがキャプチャされたら、ログを調べて WSDAPI アプリケーション エラーの原因を探すことができます。これらのログを表示するために使用するテキスト エディターは、管理者として実行する必要があります。詳細については、「 WinHTTP ログを使用した取得トラフィックの確認」を参照してください。