Avamar: Hyper-V Backup mislykkes med fejlen 'Windows Structured Exception ACCESS_VIOLATION'

Summary: KB-artikel, der indeholder detaljerede instruktioner til anvendelse af Hyper-V-hotfixes i den rigtige rækkefølge.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hyper-V-klyngesikkerhedskopieringer kan mislykkes eller fuldføres med følgende fejl:

2021-01-13 01:18:07 avhypervvss Error <42448>: 1 remote client(s) failed to complete operation on the remote file targets
2021-01-13 01:18:07 avhypervvss Info <43400>: Attempting to commit checkpoint for targets with backup success...
2021-01-13 01:18:07 avhypervvss Info <43409>: Attempting to convert backup CheckPoint to ReferrencePoint.
2021-01-13 01:18:07 avhypervvss Error <43712>: Failed to backup Virtual Machine 'PS001 <VM GUID>'
2021-01-13 01:18:07 avhypervvss Error <43712>: Failed to backup Virtual Machine 'CN001 <VM GUID>'
2021/01/13-09:18:45.98200 [hypervvss_assist]  ERROR: <41036> threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 12828
2021-01-13 01:18:45 avhypervvss Warning <41036>: threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 12828
2021/01/13-09:18:46.07500 [hypervvss_assist]  ERROR: <41037> 0: OPENSSL_Applink()+0x277287 [0xa1683e87]

Cause

De binære hotfixfiler til avhypervvss.exe er ikke blevet anvendt korrekt på klyngenoderne. Hvis de ikke anvendes i den rigtige rækkefølge, fører resultatet til intermitterende backupfejl.

Resolution

Afregistrere, afinstallere og geninstallere Avamar Client-software og Hyper-V-plug-in på alle klyngenoder. Og anvend derefter de nyeste programrettelser, afhængigt af Avamar-versionen.

Før du installerer de binære hotfixfiler, skal du kontrollere, at der ikke kører aktive sikkerhedskopier eller gendannelser på klienter. Gem flagene og konfigurationen i avhypervvss.cmd og avatar.cmd.

  1. Kør Avamar-klyngekonfigurationsguiden, og fjern registreringen af klyngeklienten.
  2. Afinstaller Avamar Hyper-V-plug-in på alle noder i klyngen.
  3. Afinstaller Avamar Windows-klienten på alle noder i klyngen.
  4. Genstart noden, hvis GLR-plug-in er konfigureret på en af noderne.
  5. Oprydning i eventuelle forældede VM-grupper på alle noder i klyngen. Kontakt om nødvendigt Dell-support.
  1. Installer Avamar Hyper-V-pluginsoftwareversion 19.10.100-135 på alle noder i klyngen og på alle noder i klyngen. 
    1. Gå ind i konsollen services.msc på hver node, og stop tjenesten "DELL Avamar Plug-in Service for Windows" på hver node.
    2. Omdøb den oprindelige winclustersvc.exe til winclustersvc-ORIG.exe.
    3. Omdøb den oprindelige winclustersvc.tlb til winclustersvc-ORIG.tlb
    4. Omdøb den oprindelige avhypervvss.exe til avhypervvss-ORIG.exe
    5. Kopiér de nye binære HF-filer avhypervvss.exe, winclustersvc.exe og winclustersvc.tlb til mappen "bin" på alle noder.
    6. Genstart tjenesten "DELL Avamar Plug-in Service for Windows" på alle klyngenoderne.
    7. Bekræft, at versionen er korrekt. Kør følgende kommando:
avhypervvss.exe --version

Output skal se ud som følgende:

Version:     19.10.100-135_HF338820

  7. Kør Avamar Cluster Configuration Wizard, og konfigurer klyngeklienten.

  1. Sæt flag og konfiguration tilbage i avhypervvss.cmd og avatar.cmd og kør sikkerhedskopier.

For Hyper-V-sikkerhedskopieringer, der fuldføres med fejl, men ikke er tilgængelige for gendannelse i Avamar Administrator-konsollen, er rettelsen blevet inkorporeret i Avamar v19.3 hotfix #327477 og nyere.

For Hyper-V RCT-sikkerhedskopier kræves konfiguration af "delt storagepath-parameter" startende i v19.4 og højere. Brug følgende KB-artikel med instruktioner til konfiguration og installation af de nyeste hotfixes til disse nyere Avamar-versioner:

KB Avamar Hyper-V VSS-plug-in: Konfiguration og installation af nyeste kumulative HF er for 19.4 og nyere

 

Affected Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000181941
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.