Avamar: Hyper-V 백업 실패 | VSS 스냅샷을 기다리는 동안 시간 초과

Summary: 이 문서에서는 클러스터 노드 간의 통신 지연으로 인해 VSS 스냅샷 동기화 시간 초과가 발생하는 Avamar Hyper-V 클러스터 백업의 실패 시나리오를 다룹니다. 이 문제는 avhypervvss.cmd 구성 파일에서 시간 초과 매개변수를 조정하면 해결됩니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hyper-V 클러스터 백업이 실패하고 다음 오류가 발생함:
공유 클러스터에서 var 디렉토리 로그:

  • avhypervvss Error <0000>: The plugin on remote client HYPERVNODE4 (192.168.1.1) terminated with code 10007: miscellaneous error
    avhypervvss Error <0000>: The remote client HYPERNODE4 failed to start its backup sub-workorder in predefined time. Please examine the log 'Hyper-V_5pm-Hyper-_V-123456789-3032-Hyper-V_VSS.log' on client HYPERVNODE4 for more information.
    avhypervvss Error <13810>: Unable to forward a ctl message to the remote client '192.168.1.1', result code: 3.
    avhypervvss Error <41106>: [AV-CLUSTER0] is unable to wakeup sub-workorder on [HYPERVNODE4].
    avhypervvss Error <42468>: Failed to update snapshot details from remote clients
    avhypervvss Error <41659>: Backup did not complete successfully

     

영향을 받는 노드의 백업 로그(C:\Program Files\avs\var명령 사용): 

  • avhypervvss Error <17114>: Timed out while waiting for a VSS snapshot synchronization event from the primary plugin.
    avhypervvss Error <41632>: Failed to setup and notify primary.
    avhypervvss Error <41659>: Backup did not complete successfully

Cause

이 오류는 Hyper-V 클러스터의 기본 노드와 보조 노드 간의 CTL 메시지 교환에서 통신 지연으로 인해 발생합니다. 이러한 지연은 VSS 스냅샷을 적시에 동기화하지 못하게 하여 백업 실패를 초래합니다. 
 

Resolution

이 문제를 해결하려면 avhypervvss.cmd 공유 클러스터에 있는 파일 var 디렉토리(에서와 같이, C:\ClusterStorage\Volume1\Avamar\var명령 사용):

다음 플래그를 추가합니다.

--request-ctl-timeout=600000
--subworkorder-timeout=20
  • --request-ctl-timeout=600000: 노드 간 내부 CTL 시간 초과를 늘립니다(기본값은 60초).
  • --subworkorder-timeout=20: 백엔드 클라이언트가 하위 작업 오더를 시작하는 대기 시간(분)을 설정합니다(기본값: 5분).

⚠️ 모든 관련 노드에서 파일이 업데이트되었는지 확인하고 백업 프로세스를 다시 시작합니다.

Affected Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000199557
Article Type: Solution
Last Modified: 30 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.