La conmutación por error de la prueba de SRA falló: No se pudieron crear instantáneas de dispositivos de réplica

Summary: Adaptador de replicación de almacenamiento (SRA) de Symmetrix Remote Data Facility (SRDF) La conmutación por error de prueba falló para algunos grupos de protección en un plan de recuperación. Error: Failed to create snapshots of replica devices. No se pudo crear una instantánea del grupo de coherencia de réplica . El comando de SRA "testFailoverStart" falló para el grupo de coherencia xx. No se pudo obtener la información de replicación. Compruebe los registros de EmcSrdfSra para obtener más información sobre el error. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Durante la ejecución de una conmutación por error de prueba de SRDF SRA de un plan de recuperación que contiene varios grupos de protección, la conmutación por error de prueba para algunos grupos de protección falló con el siguiente error: 

Error: Failed to create snapshots of replica devices. Failed to create snapshot of replica consistency group xx. SRA command 'testFailoverStart' failed for consistency group xx. Failed to fetch replication information. Please check EmcSrdfSra logs for more information on the error.


La variable EmcSrdfSraGlobalOptions.xmlEmcSrdfSraTestFailoverConfig.xml Los archivos están configurados correctamente.

La conmutación por error de prueba también fallaba cuando los grupos de protección afectados se agregaban a planes de recuperación individuales y se realizaba una conmutación por error de prueba en, con el mismo error.

Cause

Se descubrió que los grupos de dispositivos del lado de la recuperación ante desastres (DR) habían pasado a un estado no válido. Esto se ve en un symdg list salida del comando desde el servidor de SYMAPI del sitio de recuperación. Este es el motivo por el cual falló la conmutación por error de prueba de SRA.

En el symapi.log se muestran los siguientes errores:

EMC:SMBASE  emcSymValidateGroup  Group (DG_NAME) invalid; TGT dev (0x  200), Symm <array SN> ; reason; SYMAPI_C_DEV_IS_VVOL (The action cannot be performed because the specified device is a VVol device)


Se descubrió que había algunos dispositivos VVol configurados y agregados a los grupos de dispositivos (DG). Posteriormente, se eliminaron del arreglo. Los grupos de dispositivos están definidos por el usuario y están basados en host, por lo que la eliminación de los dispositivos directamente desde el arreglo PowerMax no actualiza el grupo de dispositivos.

La información del dispositivo eliminado existía en la DG y la DG pasó a un estado no válido. Cuando se realizó la conmutación por error de la prueba de SRA en el DG no válido, se produjo un error. 

Resolution

  • Se recomienda asegurarse de que el DG sea válido antes de realizar una conmutación por error de prueba de SRA en el mismo.
  • Si se omite el paso anterior y la conmutación por error de prueba de SRA se realizó y falló, el siguiente plan de acción puede ayudar a recuperar la operación de conmutación por error de SRA.
  • Elimine el DG y vuelva a crearlo desde cero. Esta es la opción más rápida.
    • symdg delete DGNAME -force
      symdg create DGNAME -type RDF2  --> RDF2 since the test failover will always happen on the Recovery Site.
      symdg -g DGNAME -sid <SN> add dev <dev_name>

             O

  • Exporte el grupo a un archivo, quite el dispositivo infractor, elimine el DG actual e importe el DG nuevamente desde el archivo.
    • symdg export DGNAME -file <filename.txt>
      Update the file to contain only the devices that should be in the DG
      symdg delete DGNAME -force
      symdg import DGNAME -file <filename.txt>
  • Realice la conmutación por error de prueba de SRA.


 

Affected Products

SRDF Adapter for VMware Site Recovery Manager
Article Properties
Article Number: 000215845
Article Type: Solution
Last Modified: 26 Aug 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.