SRA 測試容錯移轉失敗:無法建立複本裝置的快照
Summary:
Symmetrix Remote Data Facility (SRDF) 儲存複寫配接卡 (SRA) 在復原計畫中,幾個保護群組的測試容錯移轉失敗。
Error: 無法建立複本裝置的快照。無法建立複本一致性群組的快照 。一致性群組 xx 的 SRA 命令「testFailoverStart」失敗。擷取複寫資訊失敗。請檢查 EmcSrdfSra
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Symptoms
對包含多個保護組的恢復計劃執行 SRDF SRA 測試故障轉移時,幾個保護組的測試故障轉移失敗,並顯示錯誤:
Error: Failed to create snapshots of replica devices. Failed to create snapshot of replica consistency group xx. SRA command 'testFailoverStart' failed for consistency group xx. Failed to fetch replication information. Please check EmcSrdfSra logs for more information on the error.
可使用 EmcSrdfSraGlobalOptions.xml 與 EmcSrdfSraTestFailoverConfig.xml 檔已正確配置。
將受影響的保護組添加到單個恢復計劃並對其執行測試故障轉移時,測試故障轉移也失敗,並出現相同的錯誤。
Cause
已發現災難回復 (DR) 端裝置群組進入無效狀態。如畫面所示 symdg list 命令輸出自復原站點 SYMAPI 伺服器。這就是 SRA 測試故障轉移失敗的原因。
在symapi.log中會看到以下錯誤:
EMC:SMBASE emcSymValidateGroup Group (DG_NAME) invalid; TGT dev (0x 200), Symm <array SN> ; reason; SYMAPI_C_DEV_IS_VVOL (The action cannot be performed because the specified device is a VVol device)
發現有幾個 VVol 裝置已設定並新增至裝置群組 (DG)。這些稍後會從陣列中刪除。裝置群組是以主機為基礎且由使用者定義,因此直接從 PowerMax array 刪除裝置不會更新裝置群組。
已刪除的裝置資料存在於危險品內,而危險品進入無效狀態。在無效的 DG 上執行 SRA 測試容錯移轉時,失敗。
Resolution
- 建議您先確定 DG 有效,再對其執行 SRA 測試容錯移轉。
- 如果遺漏上述步驟,且 SRA 測試容錯移轉已執行但失敗,則以下行動計畫可協助復原 SRA 容錯移轉作業。
- 刪除 DG 並從頭開始重新創建。這是更快的選項。
-
symdg delete DGNAME -force symdg create DGNAME -type RDF2 --> RDF2 since the test failover will always happen on the Recovery Site. symdg -g DGNAME -sid <SN> add dev <dev_name>
-
或
- 將組匯出到檔,移除有問題的設備,刪除當前 DG,然後從檔中再次導入 DG。
-
symdg export DGNAME -file <filename.txt> Update the file to contain only the devices that should be in the DG symdg delete DGNAME -force symdg import DGNAME -file <filename.txt>
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- 執行 SRA 測試容錯移轉。
Affected Products
SRDF Adapter for VMware Site Recovery ManagerArticle Properties
Article Number: 000215845
Article Type: Solution
Last Modified: 26 Aug 2025
Version: 2
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