SRA 测试故障切换失败:无法创建副本设备的快照

Summary: Symmetrix Remote Data Facility (SRDF) Storage Replication Adapter (SRA) 恢复计划中一些保护组的测试故障切换失败。 Error: Failed to create snapshots of replica devices.无法创建副本一致性组的快照 。一致性组 xx 的 SRA 命令“testFailoverStart”失败。未能获取复制信息。请检查 EmcSrdfSra 日志,了解有关错误的更多信息。 ...

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Symptoms

在运行包含多个保护组的恢复计划的 SRDF SRA 测试故障切换时,一些保护组的测试故障切换失败,并显示错误: 

Error: Failed to create snapshots of replica devices. Failed to create snapshot of replica consistency group xx. SRA command 'testFailoverStart' failed for consistency group xx. Failed to fetch replication information. Please check EmcSrdfSra logs for more information on the error.


而 EmcSrdfSraGlobalOptions.xml 并且 EmcSrdfSraTestFailoverConfig.xml 文件配置正确。

将受影响的保护组添加到各个恢复计划并在其上执行测试故障切换时,测试故障切换也失败,并显示相同的错误。

Cause

已发现灾难恢复 (DR) 端设备组已进入无效状态。这表现在 symdg list 来自恢复站点 SYMAPI 服务器的命令输出。这就是 SRA 测试故障切换失败的原因。

symapi.log中显示以下错误:

EMC:SMBASE  emcSymValidateGroup  Group (DG_NAME) invalid; TGT dev (0x  200), Symm <array SN> ; reason; SYMAPI_C_DEV_IS_VVOL (The action cannot be performed because the specified device is a VVol device)


结果发现,配置了一些 VVol 设备并将其添加到设备组 (DG) 中。这些后来从阵列中删除。设备组基于主机且由用户定义,因此直接从 PowerMax 阵列中删除设备不会更新设备组。

已删除的设备信息存在于 DG 中,并且 DG 进入无效状态。在无效 DG 上执行 SRA 测试故障切换时失败。 

Resolution

  • 建议确保 DG 有效,然后再对其执行 SRA 测试故障切换。
  • 如果缺少上述步骤,并且执行了 SRA 测试故障切换但失败,则下面的行动计划可以帮助恢复 SRA 故障切换作。
  • 删除 DG 并从头开始重新创建。这是更快的选项。
    • symdg delete DGNAME -force
      symdg create DGNAME -type RDF2  --> RDF2 since the test failover will always happen on the Recovery Site.
      symdg -g DGNAME -sid <SN> add dev <dev_name>

             或者

  • 将组导出到文件,移除有问题的设备,删除当前 DG,然后从文件中再次导入 DG。
    • symdg export DGNAME -file <filename.txt>
      Update the file to contain only the devices that should be in the DG
      symdg delete DGNAME -force
      symdg import DGNAME -file <filename.txt>
  • 执行 SRA 测试故障切换。


 

Affected Products

SRDF Adapter for VMware Site Recovery Manager
Article Properties
Article Number: 000215845
Article Type: Solution
Last Modified: 26 Aug 2025
Version:  2
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