Data Domain:System Management Service(SMS)の概要
Summary: System Management Service(SMS)は、System Manager UIやDDコマンド ラインなどのクライアントからの受信コマンドをリスンするデーモンです。 SMS が実行されていない場合、システムは管理不能になり、UI またはコマンド ラインで応答しなくなります。ただし、バックアップ/復元機能には影響しません。 SMS のサービス キューには 8 つのコマンド スロットがあり、8 つのコマンドを並行して処理できます。 サービス キュー内のすべてのジョブが何らかの理由でスタックした場合、SMS は再起動を開始する前に 2 時間待機します。 ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
SMSの問題が発生した場合の一般的な症状:
- 「制限付きセッション」のDD-CLI
- PowerProtect DD System Manager UI(DDSM)を介した認証または対話ができません。
- DD-CLIコマンドのレポート作成
*** Error connecting to management service at "localhost" - SMSがコア ダンプを生成し、応答していない
- 無効または期限切れのライセンス(ロックID)(KB --000050243を参照)
NOTICE: Elicense refresh error: DD_DDBOOST license: **** Invalid locking id of DD_DDBOOST.. NOTICE: Elicense refresh error: DD_REPLICATION license: **** Invalid locking id of DD_REPLICATION.
Cause
SMSの問題は、応答しないコマンドまたはタイムアウトしたコマンドによってサービス キューが過負荷になったときに発生します。
サービスキューのこれらの「タイムアウト」は、次のようなさまざまな原因に起因している可能性があります。
- 基盤となるストレージまたはネットワークの問題
- 証明書またはレジストリーの問題。
- ドライバーまたはファームウェアのタイムアウト
- サービスまたはデーモンが応答しません。たとえば、メモリー リークが原因です
- 応答しないプラットフォーム モニタリング スタック(iDRAC、PTAgentなど)
- /Ddvarの容量が少なくなっています
次の例では、サービス キューがいっぱいになり、ジョブが2時間進行しなかったため、SMSが再起動されました。
「sms.log」ファイルで、次の手順を実行します。
06/15 17:48:42.745 (tid 0x3ab4400): Service Queue ----------- 8 jobs 06/15 17:48:42.745 (tid 0x3ab4400): job: 2421162, completed: NO, start_time: 1371328844356, end_time: 0, duration: 0 msec, operation: sms_enclosure_get_fans_status ... 06/15 19:51:42.823 (tid 0x3ab4400): INFO: Event posted: 341: EVT-SMS-00001: System management server restarted due to no progress for 120 minutes.
ここでは、実行中の最も古いジョブが「sms_enclosure_get_fans_status」であり、 他のすべてのサービス キュー スロットが他のジョブによって消費されていることがわかります。
結果:
- sms_enclosure_get_fans_status が生成され、ロックを取得する前に下位レイヤーに渡されました
- sms_enclosure_get_fans_status を完了できませんでした(証明: 'completed: いいえ')
- 他のジョブは、sms_enclosure_get_fans_statusが保持しているロックにアクセスする必要があるため 、 実行できません
- sms_enclosure_get_fans_statusを完了できないため、2時間後にSMSが再起動を開始するまでデッドロック状態になります
この例では、基盤となるBMCモジュール(別名iDRAC)が応答しなくなったため、SMSは発行されたコマンドを完了できませんでした。
Resolution
-
SMSがシステムで実行されているかどうかを確認します。そうでない場合、システムはUIまたはコマンド ラインにアクセスできず、「管理サービスに接続できません」などのエラーや、コマンドが無期限に応答を停止する結果となります。
- DD-CLIを使用してSMSサービスを再起動します
sms restart
注:一部のDDOSバージョンでは、このコマンドは「SEモード」に制限されています(その場合は、Dellサポートに連絡して、コマンドを調査して実行させてください)。
- DD-CLIを使用してSMSサービスを再起動します
-
SMSタイムアウトにより、コアダンプまたは予期しない再起動が発生する可能性があります。その場合は、サポート バンドルを生成し、関連するコア ダンプを収集し、テクニカル サポート プロバイダーに連絡して原因を調査します。
注:通常、SMSの問題はバックアップ/リストア機能には影響しません。SMSはDDFSファイル システムのオペレーションに影響しません。
Affected Products
Data Domain, Data DomainProducts
Data Protection, Data Backup & Protection StorageArticle Properties
Article Number: 000228244
Article Type: Solution
Last Modified: 08 Apr 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.