Cisco MDS 9396T: reinicio inesperado después de ejecutar la "prueba callhome" varias veces consecutivas

Summary: Después de configurar callhome y ejecutar el comando "callhome test", el servicio "callhome server" se bloqueará. Si el comando "callhome test" se ejecuta varias veces consecutivas, puede provocar un reinicio del switch. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

El switch MDS 9000 experimenta un bloqueo del proceso de Call Home después de la `callhome test` se emite el comando, lo que genera archivos principales. Si hay varios `callhome test` comandos se ejecutan consecutivamente, como `callhome test` seguido de `callhome test-keepalive', puede causar varias fallas en el servicio que pueden provocar un reinicio inesperado del switch.

MDS9396T# show logging last 15

2024 Nov 18 14:49:18 MDS9396T %SYSMGR-2-SERVICE_CRASHED: Service "callhome server" (PID 4459) hasn't caught signal 11 (core will be saved).

 

MDS9396T# show core
Module  Instance  Process-name     PID       Date(Year-Month-Day Time)
------  --------  ---------------  --------  -------------------------
1       1         callhome         4459      2024-11-18 14:49:18
1       1         callhome         7110      2024-11-18 14:50:41

 

MDS9396T# show system reset-reason
----- reset reason for module 1 (from Supervisor in slot 1) ---
Reason: Reset triggered due to HA policy of Reset
Service: callhome server hap reset
Version: 8.4(2e)

 

Cause

Cisco creó el error CSCwm91493 para este problema.

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwm91493Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

 

El perfil de destino está configurado para el destino "full_txt con el formato "XML" en lugar del formato "full-txt"

 

Ejemplo:

'show run call all'
callhome
email-contact example@dell.com
distribute
enable
commit
destination-profile full_txt format xml
destination-profile full_txt message-size 100000

 

Conozca las versiones afectadas:

8.4(2e)

8.4(2f)

9.4(2)

9.4(2a)

 

Resolution

Solución alternativa:

Vuelva a configurar el perfil de destino de Call Home de formato de perfil de destino full_txt formato xml a este formato de perfil de destino full_txt formato de txt completo

Ejemplo:

Cambie esto:
switch-1(config-callhome)# destination-profile full_txt
switch-1(config-callhome)# destination-profile full_txt format xml

A esto -
switch-1(config-callhome)# destination-profile full_txt
switch-1(config-callhome)# destination-profile full_txt format full-txt

Versión fija conocida:

Se abordará en un código futuro.

Affected Products

Connectrix MDS 9148S, Connectrix MDS 9148T, Connectrix MDS 9396S, Connectrix MDS 9396T
Article Properties
Article Number: 000248915
Article Type: Solution
Last Modified: 17 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.