Erreur de la gamme Cisco MDS : la chaîne d’identification du protocole n’a pas de retour chariot
Summary: Erreur sur le commutateur %DAEMON-3-SYSTEM_MSG : erreur : absence de retour chariot dans la chaîne d’identification du protocole
Symptoms
Affichage de ces erreurs dans 'show logging log' :
2024 Nov 5 03:05:01 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[20871]2024 Nov 5 03:05:03 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[7528]2024 Nov 5 03:05:04 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[7572]
Cause
Le problème peut commencer après la mise à niveau des commutateurs MDS/Nexus gérés par DCNM version 11.3 ou ultérieure.
Le commutateur rencontre le bug CSCvv24160.
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvv24160
Resolution
Les messages de journal en eux-mêmes sont inoffensifs, mais ils peuvent finir par remplir les journaux. Par conséquent, il est préférable de modifier le niveau de consignation sur le commutateur jusqu’à ce que DCNM puisse être mis à niveau vers la version fixe.
Solution de contournement :
1. Effectuez les configurations suivantes sur le commutateur : Processus de niveau de journalisation 2
2. Augmentez l’intervalle d’interrogation DCNM au maximum (15 minutes) pour réduire le nombre d’entrées de log.
Pour ce faire, accédez à la page Administration de l’interface utilisateur Web -> Propriétés du serveur. Localisez propertycdp.pollingInterval et augmentez la valeur à un nombre plus grand (300 secondes par défaut), comme 600 ou 900 secondes.
Résolution : Mise à niveau vers NDFC 12.x
Additional Information
L’abaissement du niveau de journalisation d’un processus du niveau 3 (Erreur) au niveau 2 (Critique) se traduit par une diminution du nombre de messages de journal enregistrés. Seuls les messages classés comme « critiques » ou plus graves seront consignés. Voici un bref aperçu de ce que cela signifie :
Niveau 3 (erreur) : Consigne les conditions d’erreur, c’est-à-dire les problèmes qui peuvent toujours permettre au système de continuer à fonctionner, mais qui indiquent un problème qui nécessite une attention particulière.
Niveau 2 (critique) : Consigne les conditions critiques, c’est-à-dire les problèmes plus graves qui pourraient causer des problèmes importants ou des défaillances du système.
En définissant le niveau de journalisation sur 2, il filtre les messages d’erreur moins graves et ne capture que les problèmes critiques, ce qui peut réduire le volume des journaux et se concentrer sur les problèmes les plus graves.