Сбой извлечения больших файлов VHD с помощью Проводника Windows

Summary: При попытке извлечь большие ZIP-файлы с помощью проводника Windows происходит сбой процесса извлечения с неопределенной ошибкой: Ошибка 0x80004005. Неуказанная ошибка Ошибка в данных: VHD-файл ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Проводник завершает процесс извлечения, но во время него отображается сообщение «Ошибка данных».

  • Переменная .vhd Не удалось правильно извлечь или скопировать файл (виртуальный жесткий диск).

  • Размер и содержимое ZIP-архива выглядят нормально.

  • При использовании PowerShell или сторонних средств распаковки проблем не обнаружено.

изображение сообщения об ошибке Error 0x80004005

Cause

Проводник Windows имеет ограничения при обработке больших .ZIP архивы, содержащие большие файлы VHD (обычно >объемом 3 Гбайт). Это часто приводит к сбоям неполного извлечения или копирования по следующим причинам:

  • Ограничения размера файлов во встроенном распаковщике

  • Несогласованность сжатия

  • Отсутствие надежной коррекции ошибок во время извлечения

 

Resolution

Для успешного извлечения этих ZIP-файлов используйте один из следующих альтернативных методов:

Команда в PowerShell

Пример 

(средство Microsoft/стороннего производителя) PowerShell.   Expand-Archive -Path "C:\8.4\ddve-hyperv-8.4.0.0-1175068.zip" -DestinationPath "C:\8.4\Extracted\"

Другие инструменты извлечения

Проверьте наличие одобренной компанией профессиональной утилиты для извлечения/расширения файла. 
Сторонние инструменты пользовательского интерфейса и интерфейса командной строки 

 

Affected Products

Storage Integrator, Data Domain Virtual Edition, PowerProtect Data Domain Management Center, PowerPath for Windows
Article Properties
Article Number: 000334778
Article Type: Solution
Last Modified: 25 Jun 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.