PowerProtect: L'installazione di MSAPPAGENT non riesce se non sono disponibili diritti di accesso interattivo sull'account di backup

Summary: Le policy di protezione con riconoscimento dell'applicazione di PowerProtect Data Manager richiedono che nell'account del servizio di backup sia abilitato l'accesso interattivo a Windows. Se questa impostazione è disabilitata, l'installazione dell'agent non riesce, impedendo la configurazione e la protezione degli asset delle VM. ...

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Symptoms

  • La policy di protezione con riconoscimento dell'applicazione della macchina virtuale non riesce a configurare l'asset della macchina virtuale.
  • I registri di vProxy Agent mostrano errori di autenticazione, ad esempio:
2025-07-14T20:15:34.181-07:00 ERROR: 10.11.12.13:42530: Unable to authenticate user 'user1234'. Logon failure: the user has not been granted the requested logon type at this computer.
  • PowerProtect Data Manager non riesce a configurare l'asset VM durante la configurazione della policy di protezione.
  • vProxy installa correttamente vProxy Agent sulla macchina virtuale.
  • Installazione di MSAPPAGENT ha esito negativo quando viene eseguito nell'account del servizio di backup.
  • Windows revoca la richiesta di esecuzione per mancanza di diritti di accesso interattivo.

Versioni interessate

  • Tutte le versioni supportate di PowerProtect Data Manager

Cause

I criteri di sicurezza di Windows impediscono agli account non interattivi di eseguire processi che richiedono il contesto dell'utente. quando la proprietà del MSAPPAGENT Il programma di installazione viene avviato con un account del servizio di backup senza diritti di accesso interattivo, il sistema operativo revoca la richiesta di esecuzione, causando il fallimento dell'installazione.


Configurazioni e impostazioni interessate

  • Account del servizio di backup utilizzato nella policy di protezione application-aware per macchine virtuali PowerProtect Data Manager
  • Accesso interattivo disabilitato in:
    • Criteri di gruppo: Ad esempio "Nega accesso locale"
    • Criteri di sicurezza locali: Ad esempio "Nega accesso tramite Servizi Desktop remoto"

Resolution

Versione fissa

  • Non è disponibile una versione fissa.

Soluzione alternativa:

Per risolvere questo problema, abilitare l'accesso interattivo per l'account del servizio di backup utilizzato in PowerProtect Data Manager.

Procedura:

  1. Abilitare l'accesso interattivo per l'account del servizio di backup utilizzato in PowerProtect Data Manager.
  2. Applicare le modifiche utilizzando criteri di sicurezza locali o di gruppo in base alle esigenze.
    1. Criteri di gruppo (gpmc.msc) su un controller di dominio
Andare a: Configurazione del computerImpostazioni di WindowsImpostazioni di protezioneCriteri localiassegnazione dei diritti utente 
  1. Criteri di sicurezza locali (secpol.msc) sulla macchina virtuale o sul sistema aggiunto a un dominio
Andare a: Policy localiassegnazione dei diritti utente 
  1. Individuare ed esaminare le seguenti policy:
    • Nega l'accesso locale
    • Negare l'accesso tramite Servizi Desktop remoto
  2. Assicurarsi che l'account del servizio di backup non sia elencato in nessuna delle due policy.
  3. Se vengono apportate modifiche, riavviare la macchina virtuale o forzare un aggiornamento di Criteri di gruppo utilizzando:
gpupdate /force
  1. Riprovare la configurazione con riconoscimento dell'applicazione della macchina virtuale.

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000361291
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  2
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