Microsoft App Agent - Yeniden başlatmanın gerekip gerekmediğini belirleme

Summary: KB, Microsoft App Agent'ı yükseltmenin veya kaldırmanın yeniden başlatma gerektirip gerektirmeyeceğini belirlemek içindir. Bu genellikle Itempoint ile Table Level Recovery seçeneği etkinleştirildiğinde oluşur. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Tablo Düzeyinde Kurtarma ile Microsoft App Agent'ın Kaldırılması veya Yükseltilmesi için yeniden başlatma gerekir.

 

Cause

Microsoft App Agent ile Table Level Recovery ile yüklenen belirli sürücüler nedeniyle yeniden başlatmalar gerekebilir.

 

Resolution

Yükseltilmiş bir PowerShell çalıştırın ve itempoint'in yüklü olup olmadığına bağlı olarak belirli değerler döndüren aşağıdaki komutu çalıştırın: Bu nedenle, kaldırıldığında veya yükseltme sırasında sunucunun büyük olasılıkla yeniden başlatılması gerekir.
(Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'

Örneğin:

PS C:\Users\administrator.AMER> (Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'
False
PS C:\Users\administrator.AMER> (Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'
True

Özetle, yol içindeki bu değer için kayıt defterini sorgulayın ve varsa True, else false - diyor.

False = ideal olarak yeniden başlatma yok - İşletim sistemi yine de yeniden başlatma isteminde bulunabilir ancak Agent'ı temel almaz**.
True = reboot büyük olasılıkla gerekli.

 

Additional Information

DDBMS windows kayıt defteri

Products

Microsoft App Agent, PowerProtect App Direct
Article Properties
Article Number: 000375390
Article Type: Solution
Last Modified: 15 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.