Data Protection Advisor (DPA): NetWorker Workflow Configuration report missing some data

Summary: NetWorker Workflow Configuration report is missing data for fields like Auto-Start Enabled, Start Time, Interval, and Restart Window.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Workflow Configuration report returns no data for some fields including Auto-Start Enabled, Start Time, Interval, and Restart Window.

Cause

Since DPA 19.1, the NetWorker Workflow Configuration report collects extra data using the NetWorker Configuration REST Application Programming Interface (API) request. This option is disabled by default.

Resolution

To address the issue:       

  1. Configure NetWorker credentials in DPA to make the Rest API calls. Use NMC administrator user or create a new user using NMC or CLI in NetWorker with User role privileges.

  2. Go to the DPA console > Inventory > Object Library > Applications and select the NetWorker node.

  3. Select the Data Collection tab, highlight the NetWorker Configuration request and click Edit

  4. Set the request option Use server REST API to true (default is false). Also, set the Credentials to use the DPA credentials created in step 1 above.

DPA settings to enable REST API
  1. Run a manual data collection or wait for the schedule data collection to run and complete successfully. Once it completes, the missing fields should be populated in the report.

Contact DELL Technical Support for more information or if further assistance is needed.

Affected Products

Data Protection Advisor

Products

NetWorker
Article Properties
Article Number: 000174098
Article Type: Solution
Last Modified: 18 Jul 2025
Version:  4
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