XtremIO: High CPU performance data is reported for XMS 6.2.0.x versions (Dell Correctable)
Summary: XtremIO Management Server (XMS) Central Processing Unit (CPU) performance may be reported as close to 100% in vCenter.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
CPU performance for an XtremIO Management Server (XMS) running 6.2.0-x code may display as being exceptionally high.
The XMS CPU shows at more than 80% for an extended period of time when this issue occurs.
For example, in vCenter, CPU Utilization values may be as high as 100% even though the CPU value from within the XMS is not at 100%.
The following is an example of vCenter showing extremely high CPU utilization: 
Cause
This issue is due to an XMS software issue related to CPU performance data collection.
Resolution
The issue has been resolved in the XMS versions XMS 6.2.1 and later.
An alternative option which may resolve the issue is to add two additional CPU cores to the vXMS. This may alleviate the high CPU usage and stop CPU consumption alerts customers may receive from vCenter.
Additional Information
This issue is related to the issues of the following KB article: XtremIO: No performance data available on XMS versions 6.x
Affected Products
XtremIO FamilyProducts
XtremIO Family, XtremIO X1, XtremIO X2Article Properties
Article Number: 000055529
Article Type: Solution
Last Modified: 07 Oct 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.