PowerScale: IP adresa služby SmartConnect se může po upgradu na verzi 8.2 nacházet na více uzlech
Summary: Tento článek popisuje, jak identifikovat a vyřešit zjištěné problémy, když se dvě nebo více stejných IP adres služby SmartConnect (SSIP) nacházejí na dvou nebo více uzlech.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Potvrzení upgradu z verzí starších než OneFS 8.2 a přechod na OneFS 8.2.x může vést k duplicitním SSIP na dvou nebo více uzlech v clusteru. Příznaky, ke kterým dochází během problému, jsou selhání příkazu ping na SSIP a selhání překladu názvu zóny přidruženého k tomuto SSIP.
Chcete-li zjistit, zda jsou v clusteru duplicitní adresy SSIP, spusťte následující příkaz:
# isi_for_array ifconfig | grep "zone 0"
Z vrácených SSIP adres vyhledejte duplicitní adresy mezi uzly.
Například:
cluster-1: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0 cluster-3: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0
Cause
K tomu může dojít, když současně dojde ke změně v rámci našeho síťového démona isi_flexnet_d a potvrzení upgradu.
Resolution
Problém vyřešíte restartováním isi_dnsiq_d a isi_smartconnect_d démony na ovlivněných uzlech a pak je znovu vyhodnoťte.
# isi_for_array -n <affected nodes> 'pkill isi_dnsiq_d isi_smartconnect_d'
Poznámka: Ve výše uvedeném příkladu vypadá příkaz takto:
# isi_for_array -n1,3 'pkill isi_dnsiq_d isi_smartconnect_d'
Affected Products
IsilonProducts
PowerScale OneFSArticle Properties
Article Number: 000170716
Article Type: Solution
Last Modified: 21 May 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.