PowerScale: La dirección IP del servicio SmartConnect puede residir en varios nodos después de la actualización a 8.2

Summary: En este artículo, se describe cómo identificar y resolver problemas encontrados cuando dos o más direcciones IP de servicio de SmartConnect (SSIP) se encuentran en dos o más nodos.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Confirmar una actualización desde versiones anteriores a OneFS 8.2 y pasar a OneFS 8.2.x puede dar lugar a SSIP duplicadas en dos o más nodos del clúster. Los síntomas que se observan durante el problema son la falla de hacer ping a la SSIP y la falla de resolución del nombre de zona asociado con esa SSIP. 

Para identificar si hay direcciones SSIP duplicadas en el clúster, ejecute el siguiente comando:

# isi_for_array ifconfig | grep "zone 0"

En las SSIP devueltas, busque duplicados entre los nodos.
Por ejemplo:

cluster-1: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0 cluster-3: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0

Cause

Esto puede ocurrir cuando hay un cambio simultáneo desde dentro de nuestro demonio de red isi_flexnet_d y el compromiso de actualización.

Resolution

Para resolver el problema, reinicie isi_dnsiq_d y isi_smartconnect_d demonios en los nodos afectados y, a continuación, vuelva a evaluar.

# isi_for_array -n <affected nodes> 'pkill isi_dnsiq_d isi_smartconnect_d'
 
Nota: En el ejemplo anterior, el comando tiene el siguiente aspecto:
# isi_for_array -n1,3 'pkill isi_dnsiq_d isi_smartconnect_d'

Affected Products

Isilon

Products

PowerScale OneFS
Article Properties
Article Number: 000170716
Article Type: Solution
Last Modified: 21 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.