PowerScale: L'indirizzo IP del servizio SmartConnect può risiedere su più nodi dopo l'aggiornamento alla versione 8.2
Summary: Questo articolo descrive come identificare e risolvere i problemi rilevati quando due o più SmartConnect Service IP (SSIP) identici si trovano su due o più nodi.
Symptoms
Il commit di un aggiornamento da versioni precedenti a OneFS 8.2 e il passaggio a OneFS 8.2.x può comportare SSIP duplicati su due o più nodi del cluster. I sintomi riscontrati durante il problema sono la mancata esecuzione del ping dell SSIP e la mancata risoluzione del nome della zona associato a tale SSIP.
Per identificare se nel cluster sono presenti indirizzi SSIP duplicati, eseguire il seguente comando:
# isi_for_array ifconfig | grep "zone 0"
Dagli SSIP restituiti, cercare eventuali duplicati tra i nodi.
Per esempio:
cluster-1: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0 cluster-3: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0
Cause
Ciò può verificarsi quando si verifica una modifica simultanea dall'interno del daemon di rete isi_flexnet_d e il commit dell'aggiornamento.
Resolution
Per risolvere il problema, riavviare il isi_dnsiq_d e isi_smartconnect_d daemon sui nodi interessati , quindi rivalutare.
# isi_for_array -n <affected nodes> 'pkill isi_dnsiq_d isi_smartconnect_d'
# isi_for_array -n1,3 'pkill isi_dnsiq_d isi_smartconnect_d'