Integrated Data Protection Appliance:2.7.6のアップグレード後にAD/LDAP認証情報を使用してDPCにアクセスすると、断続的なアクセスの問題とSSOの失敗が発生します。
Summary: IDPA 2.7.6アップグレード/DPC 19.9アップグレード後、AD/LDAP認証情報を使用してアップグレードしようとすると、DPCにアクセスとSSOの問題が表示されます。
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Symptoms
- AD/LDAPソースはDPCで構成されており、AD/LDAP認証情報を使用してDPCにアクセスしようとすると、このエラーで断続的に失敗しますが、機能する場合があります。さらに、Cookieとキャッシュがクリアされた場合、これは恒久的な解決策ではありません。
- AD/LDAP認証情報を使用してログに記録されている場合、DPCに統合されたシステムへのSSOは同じエラーで失敗します。
- 開発者ツールには、502 bad gateway エラーが表示されます。
2024/04/09 10:53:10 [error] 64587#64587: *14150 upstream sent too big header while reading response header from upstream, client: 172.26.130.97, server: xxxxx.xxxxx.xxxxx request: "GET /auth/realms/DPC/protocol/openid-connect/authscope=openid+profile&response_type=code&redirect_uri=https%3A%2F%2Fxxxxx.xxxxx.xxxxx&state=YWK9IJANc0Tn9c8dhSA_MAOfja3DSairR_Ag8kLker4&nonce=uPOO0ZLBU9WzHhuaR45e6q7PqYCbYOEi8Kk5sttJA5I&client_id=98ce7c21-0ec2-4d9b-9bde-125d940f212f HTTP/1.1", upstream: "https://127.0.0.1:8143/auth/realms/DPC/protocol/openid-connect/auth?scope=openid+profile&response_type=code&redirect_uri=https%3A%2F%2Fmin-dp-idpa01-dpc-01.vcdservices.local&state=YWK9IJANc0Tn9c8dhSA_MAOfja3DSairR_Ag8kLker4&nonce=uPOO0ZLBU9WzHhuaR45e6q7PqYCbYOEi8Kk5sttJA5I&client_id=98ce7c21-0ec2-4d9b-9bde-125d940f212f", host: "xxxxx.xxxxx.xxxxx", referrer: "https://xxxxx.xxxxx.xxxxxx/"
Cause
NGINXは、レスポンスヘッダーを処理する際に、処理できるヘッダーのサイズに制限を設けます。ヘッダーがこの制限を超えると、NGINXは接続を拒否し、502 bad gatewayエラーが発生します。
Resolution
1.etc/nginx/nginx.confファイルで、変数を設定した後 keepalive_timeout 以下の行を追加します。
proxy_buffer_size 128k; proxy_buffers 4 256k; proxy_busy_buffers_size 256k;
2.この設定を保存します。
3.nginxサービスを再起動します
service nginx restart
4.動作が変わった場合は、再度テストします。
Affected Products
Data Protection CentralArticle Properties
Article Number: 000225360
Article Type: Solution
Last Modified: 27 May 2024
Version: 2
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