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VDP: Anmeldung bei VDP schlägt mit dem Fehler „Verbindung mit der angeforderten VDP-Appliance kann nicht hergestellt werden“ fehl

Summary: Anmeldung bei VDP-Appliance von vCenter aus schlägt mit dem Fehler „Verbindung mit der angeforderten VDP-Appliance kann nicht hergestellt werden“ fehl.

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Article Content


Symptoms

Das Problem tritt nach dem VDP-Upgrade auf.

Die Anmeldung bei der VDP-Appliance-GUI von vCenter aus schlägt mit dem folgenden Fehler fehl:
„Verbindung mit der angeforderten VDP-Appliance kann nicht hergestellt werden“ 
 
kA23a000000GHjXCAW_3_0

Die Überprüfung der Protokolldatei /usr/local/avamar/var/vdr/server_logs/vdr-configure.log zeigt, dass der Tomcat-Prozess der VDP-Konfiguration versucht, den Status des AV-Installationsprozesses zu definieren. Er durchläuft die folgenden Status in einer Schleife:
> 2020-01-08 08:55:48,506 INFO  [pool-25-thread-1]-scheduler.AviStateMachine: Switching state from LOGOUT_ERROR to LOGGED_OUT
> 2020-01-08 08:55:48,506 INFO  [pool-25-thread-1]-scheduler.AviStateMachine: Switching state from LOGGED_OUT to LOGOUT_ERROR
> 2020-01-08 08:56:20,042 INFO  [pool-25-thread-1]-scheduler.AviStateMachine: Switching state from LOGOUT_ERROR to LOGGED_OUT
> 2020-01-08 08:56:20,043 INFO  [pool-25-thread-1]-scheduler.AviStateMachine: Switching state from LOGGED_OUT to LOGOUT_ERROR
Überprüfen Sie in den Einstellungen, ob ein ISO mit der VDP-Appliance verbunden ist. Trennen Sie es und starten Sie den emwebapp.sh-Service neu. Dadurch wird der Fehler in der Regel behoben.
Wenn das Problem jedoch weiterhin besteht, überprüfen Sie das Verzeichnis „/data01/avamar/repo/packages“, ob unter dem Paketverzeichnis weiterhin ein AVP-Paket aufgeführt wird.
Überprüfen Sie die Protokolldatei „/usr/local/avamar-tomcat/logs/catalina.out“ auf mehrere Fehler mit der Meldung:
 
„HTTP header too large“

Cause

Der Eintrag „maxHttpHeaderSize“ fehlte in der Konfigurationsdatei „/usr/local/avamar-tomcat/conf/server.xml“.  

Die Datei ähnelt dem folgenden Beispiel:
 
Connector SSLEnabled="true" Server="Avamar" ciphers="TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_....." clientAuth="false" maxKeepAliveRequests="1" maxThreads="150" port="8543" protocol="org.apache.coyote.http11.Http11NioProtocol" scheme="https" secure="true" sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2"/>

Standardmäßig sollte in der Konfigurationsdatei „/usr/local/avamar-tomcat/conf/server.xml“ der Abschnitt für Port 8543 den Eintrag „maxHttpHeaderSize“ enthalten, der ähnlich wie folgt aussieht:
 
<Connector port="8543" maxHttpHeaderSize="32768" protocol="org.apache.cyote.http11.Http11NioProtocol" SSLEnabled="true" maxThreads="150" scheme="https" secure="true" maxKeepAliveRequests="1" clientAuth="false" sslEnabledProtocols="TLSv1.1,TLSv1.2" Server=" Avamar ciphers="TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA......" />

In diesem Fall fehlte der Eintrag maxHttpHeaderSize="32768“ und musste manuell hinzugefügt werden.

Resolution

Verfahren:
  1. Erstellen Sie eine Kopie der Datei /usr/local/avamar-tomcat/conf/server.xml:
cp -p /usr/local/avamar-tomcat/conf/server.xml /usr/local/avamar-tomcat/conf/server.xml-BEFOREDATE
  1. Bearbeiten Sie die Server-.xml-Datei:
vi /usr/local/avamar-tomcat/conf/server.xml
  1. Fügen Sie im Abschnitt für den Port 8543 den Eintrag maxHttpHeaderSize="32768“ hinzu:
Es sollte ähnlich wie folgt aussehen:
 
Connector SSLEnabled="true" Server="Avamar" ciphers="TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_RSA_WITH_AES_ ...." clientAuth="false" maxKeepAliveRequests="1" maxThreads="150" port="8543" maxHttpHeaderSize="32768"  protocol="org.apache.coyote.http11.Http11NioProtocol" scheme="https" secure="true" sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2"/>
  1. Speichern Sie die Datei und starten Sie die Webdienste neu:
emwebapp.sh --restart

Stellen Sie eine Verbindung zur VDP-Appliance her. Das Problem sollte gelöst sein.

Additional Information

Der Eintrag „maxHttpHeaderSize“ sollte standardmäßig in allen VDP-Versionen gefunden werden. Er war in der Datei aus unbekannten Gründen, die geprüft werden sollten, nicht vorhanden.

Article Properties


Affected Product

Avamar

Product

Avamar, Avamar Virtual Edition

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution