Importing Device Groups Fail with "Cannot commit group changes to db: The Symmetrix ID unknown"
Summary: This article provides the resolution for the error "Cannot commit group changes to database: The Symmetrix ID is not known."
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Symdg importall fails:
symdg importall -f filename.txt Creating device group 'GroupName' Adding STD device 03342 as DEV001... Adding STD device 0334A as DEV002... Adding STD device 03352 as DEV003... Adding RTGT device 034C6 as RTGT001... Adding RTGT device 034CE as RTGT002... Adding RTGT device 034D6 as RTGT003... Cannot commit group changes to database: The Symmetrix ID is not known.
Cause
GNS is enabled in the environment.
The import operation failed because the GNS daemon did not recognize one of the arrays. This is because one of the arrays was not discovered on the host.
Resolution
Stop and start the GNS daemon and then the symdg importall is successful.
stordaemon shutdown storgnsd stordaemon start storgnsd
Affected Products
Solutions EnablerProducts
SymmetrixArticle Properties
Article Number: 000025233
Article Type: Solution
Last Modified: 07 Jan 2026
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.